[Coursera C++程序设计] 第三周作业

编程题#1

来源: POJ (Coursera声明:在POJ上完成的习题将不会计入Coursera的最后成绩。)

注意: 总时间限制: 1000ms 内存限制: 65536kB

描述

下面程序输出的结果是:

0

5

请填空:

 
1
2
3
4
5
6
7
8
9
10
11
12
13
#include <iostream>
using namespace std ;
class A {
public :
int val ;
//
} ;
main ( ) {
A a ;
cout << a . val << endl ;
a . GetObj ( ) = 5 ;
cout << a . val << endl ;
}

输入

输出

0

5

样例输入

 
1

样例输出

 
1
2
0
5

提示

所缺代码具有如下形式:

 
1
2
3
4
A(_________________ ){ val = n; }
________________ GetObj() {
return _________________;
}
#include <iostream>
using namespace std;
class A {
public:
	int val;


	// 在此处补充你的代码  
	A(int n = 0) { val = n; }
	//A(){ val = 0; }  //考察构造函数和引用
	int& GetObj() {
		return val;    //返回val的引用  
	}

};
main() {
	A a;
	cout << a.val << endl;
	a.GetObj() = 5;
	cout << a.val << endl;
}

编程题 #2

来源: POJ (Coursera声明:在POJ上完成的习题将不会计入Coursera的最后成绩。)

注意: 总时间限制: 1000ms 内存限制: 65536kB

描述

下面程序的输出是:

10

请补足Sample类的成员函数。不能增加成员变量。

 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <iostream>
using namespace std ;
class Sample {
public :
int v ;
Sample ( int n ) : v ( n ) { }
//
} ;
int main ( ) {
Sample a ( 5 ) ;
Sample b = a ;
cout << b . v ;
return 0 ;
}

输入

输出

10

样例输入

 
1

样例输出

 
1
10
#include <iostream>
using namespace std;
class Sample{
public:
    int v;
    Sample(int n):v(n) { }

	// 在此处补充你的代码
	Sample(Sample & c) {//考察复制构造函数
		v = c.v * 2;
	}

};
int main() {
    Sample a(5);
    Sample b = a;
    cout << b.v;
    return 0;
}

编程题 #3

来源: POJ (Coursera声明:在POJ上完成的习题将不会计入Coursera的最后成绩。)

注意: 总时间限制: 1000ms 内存限制: 65536kB

描述

下面程序的输出结果是:

5,5

5,5

请填空:

 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <iostream>
using namespace std ;
class Base {
public :
int k ;
Base ( int n ) : k ( n ) { }
} ;
class Big {
public :
int v ; Base b ;
//
} ;
int main ( ) {
Big a1 ( 5 ) ; Big a2 = a1 ;
cout << a1 . v << " , " << a1 . b . k << endl ;
cout << a2 . v << " , " << a2 . b . k << endl ;
return 0 ;
}

输入

输出

5,5

5,5

样例输入

 
1

样例输出

 
1
2
5,5
5,5

提示

所缺代码具有如下形式:

 
1
2
Big ________________{ }
Big ________________{ }

#include <iostream>
using namespace std;
class Base {
public:
    int k;
    Base(int n):k(n) { }
};
class Big {
public:
    int v; Base b;

	// 在此处补充你的代码
	Big(int n) :v(n),b(v){ }//考察成员对象


};
int main() {
    Big a1(5); Big a2 = a1;
    cout << a1.v << "," << a1.b.k << endl;
    cout << a2.v << "," << a2.b.k << endl;
    return 0;
}


编程题#4:魔兽世界之一:备战

来源: POJ (Coursera声明:在POJ上完成的习题将不会计入Coursera的最后成绩。)

注意: 总时间限制: 1000ms 内存限制: 65536kB

描述

魔兽世界的西面是红魔军的司令部,东面是蓝魔军的司令部。两个司令部之间是依次排列的若干城市。

红司令部,City 1,City 2,……,City n,蓝司令部

两军的司令部都会制造武士。武士一共有 dragon 、ninja、iceman、lion、wolf 五种。每种武士都有编号、生命值、攻击力这三种属性。

双方的武士编号都是从1开始计算。红方制造出来的第n个武士,编号就是n。同样,蓝方制造出来的第n个武士,编号也是n。

武士在刚降生的时候有一个生命值。

在每个整点,双方的司令部中各有一个武士降生。

红方司令部按照iceman、lion、wolf、ninja、dragon的顺序循环制造武士。

蓝方司令部按照lion、dragon、ninja、iceman、wolf的顺序循环制造武士。

制造武士需要生命元。

制造一个初始生命值为m的武士,司令部中的生命元就要减少m个。

如果司令部中的生命元不足以制造某个按顺序应该制造的武士,那么司令部就试图制造下一个。如果所有武士都不能制造了,则司令部停止制造武士。

给定一个时间,和双方司令部的初始生命元数目,要求你将从0点0分开始到双方司令部停止制造武士为止的所有事件按顺序输出。

一共有两种事件,其对应的输出样例如下:

1) 武士降生

输出样例: 004 blue lion 5 born with strength 5,2 lion in red headquarter

表示在4点整,编号为5的蓝魔lion武士降生,它降生时生命值为5,降生后蓝魔司令部里共有2个lion武士。(为简单起见,不考虑单词的复数形式)注意,每制造出一个新的武士,都要输出此时司令部里共有多少个该种武士。

2) 司令部停止制造武士

输出样例: 010 red headquarter stops making warriors

表示在10点整,红方司令部停止制造武士

输出事件时:

首先按时间顺序输出;

同一时间发生的事件,先输出红司令部的,再输出蓝司令部的。

输入

第一行是一个整数,代表测试数据组数。

每组测试数据共两行。

第一行:一个整数M。其含义为, 每个司令部一开始都有M个生命元( 1 <= M <= 10000)。

第二行:五个整数,依次是 dragon 、ninja、iceman、lion、wolf 的初始生命值。它们都大于0小于等于10000。

输出

对每组测试数据,要求输出从0时0分开始,到双方司令部都停止制造武士为止的所有事件。

对每组测试数据,首先输出"Case:n" n是测试数据的编号,从1开始 。

接下来按恰当的顺序和格式输出所有事件。每个事件都以事件发生的时间开头,时间以小时为单位,有三位。

参考答案:

#include <iostream>  
#include <cstdio>  
#include <string>  
using namespace std;
const int  WARRIOR_NUM = 5;
/*
string Warrior::names[WARRIOR_NUM] = { "dragon","ninja","iceman","lion","wolf" };
红方司令部按照 iceman、lion、wolf、ninja、dragon 的顺序制造武士。
蓝方司令部按照 lion、dragon、ninja、iceman、wolf 的顺序制造武士。
*/
class Headquarter;
class Warrior
{
private:
	Headquarter * pHeadquarter;
	int kindNo; //武士的种类编号 0 dragon 1 ninja 2 iceman 3 lion 4 wolf  
	int no;
public:
	static string names[WARRIOR_NUM];
	static int initialLifeValue[WARRIOR_NUM];
	Warrior(Headquarter * p, int no_, int kindNo_);
	void PrintResult(int nTime);
};

class Headquarter
{
private:
	int totalLifeValue;
	bool stopped;
	int totalWarriorNum;
	int color;
	int curMakingSeqIdx; //当前要制造的武士是制造序列中的第几个  
	int warriorNum[WARRIOR_NUM]; //存放每种武士的数量  
	Warrior * pWarriors[1000];
public:
	friend class Warrior;
	static int makingSeq[2][WARRIOR_NUM]; //武士的制作顺序序列  
	void Init(int color_, int lv);
	~Headquarter();
	int Produce(int nTime);
	string GetColor();

};
Warrior::Warrior(Headquarter * p, int no_, int kindNo_) {
	no = no_;
	kindNo = kindNo_;
	pHeadquarter = p;
}
void Warrior::PrintResult(int nTime)
{
	string color = pHeadquarter->GetColor();
	printf("%03d %s %s %d born with strength %d,%d %s in %s headquarter\n",
		nTime, color.c_str(), names[kindNo].c_str(), no, initialLifeValue[kindNo],
		pHeadquarter->warriorNum[kindNo], names[kindNo].c_str(), color.c_str());
}
void Headquarter::Init(int color_, int lv)
{
	color = color_;
	totalLifeValue = lv;
	totalWarriorNum = 0;
	stopped = false;
	curMakingSeqIdx = 0;
	for (int i = 0; i < WARRIOR_NUM; i++)
		warriorNum[i] = 0;
}

Headquarter::~Headquarter() {
	for (int i = 0; i < totalWarriorNum; i++)
		delete pWarriors[i];
}

int Headquarter::Produce(int nTime)
{

	if (stopped)
		return 0;
	int searchingTimes = 0;
	while (Warrior::initialLifeValue[makingSeq[color][curMakingSeqIdx]] > totalLifeValue &&
		searchingTimes < WARRIOR_NUM) {
		curMakingSeqIdx = (curMakingSeqIdx + 1) % WARRIOR_NUM;
		searchingTimes++;
	}
	int kindNo = makingSeq[color][curMakingSeqIdx];
	if (Warrior::initialLifeValue[kindNo] > totalLifeValue) {
		stopped = true;
		if (color == 0)
			printf("%03d red headquarter stops making warriors\n", nTime);
		else
			printf("%03d blue headquarter stops making warriors\n", nTime);
		return 0;
	}
	//制作士兵:  
	totalLifeValue -= Warrior::initialLifeValue[kindNo];
	curMakingSeqIdx = (curMakingSeqIdx + 1) % WARRIOR_NUM;
	pWarriors[totalWarriorNum] = new Warrior(this, totalWarriorNum + 1, kindNo);
	warriorNum[kindNo]++;
	pWarriors[totalWarriorNum]->PrintResult(nTime);
	totalWarriorNum++;
	return 1;
}

string Headquarter::GetColor()
{
	if (color == 0)
		return "red";
	else
		return "blue";
}

string Warrior::names[WARRIOR_NUM] = { "dragon","ninja","iceman","lion","wolf" };
int Warrior::initialLifeValue[WARRIOR_NUM];
int Headquarter::makingSeq[2][WARRIOR_NUM] = { { 2,3,4,1,0 },{ 3,0,1,2,4 } }; //两个司令部武士的制作顺序序列  

int main() {
	int t;
	int m;
	Headquarter RedHead, BlueHead;
	cin >> t;
	int nCaseNo = 1;
	while (t--) {
		printf("Case:%d\n", nCaseNo++);
		cin >> m;
		for (int i = 0; i < WARRIOR_NUM; i++)
			cin>>Warrior::initialLifeValue[i];
		RedHead.Init(0, m);
		BlueHead.Init(1, m);
		int nTime = 0;
		while (true) {
			int tmp1 = RedHead.Produce(nTime);
			int tmp2 = BlueHead.Produce(nTime);
			if (tmp1 == 0 && tmp2 == 0)
				break;
			nTime++;
		}
	}

	return 0;
}

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值