poj 2239 G - Selecting Courses

问题描述

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

输入

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

输出

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

样例输入

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

样例输出

4


二分图的匹配,同上次hdu 1085一样,匈牙利算法;

可能唯一的不算小技巧的 小技巧就是把日期,换成天,即int c=(星期几 -1)*12+第几节课,然后存储c;

代码如下:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

int p,n;
int ma[301][301];
int vis[301];//记录人的访问情况
int link[301];

bool find(int x)
{
    for(int j=1;j<=12*7;j++)
    {
        if(ma[x][j]&&!vis[j])
        {
            vis[j]=1;
            if(!link[j]||find(link[j]))
            {
                link[j]=x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(ma,0,sizeof(ma));
        memset(link,0,sizeof(link));
        for(int i=1;i<=n;i++)
        {
            int j;
            scanf("%d",&j);
            for(int jj=1;jj<=j;jj++)
            {
                int a;int b;
                scanf("%d%d",&a,&b);
                int c=(a-1)*12+b;
                ma[i][c]=1;
            }
        }
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                sum++;

        }
        printf("%d\n",sum);

    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值