hdu 1051 Wooden Sticks

问题描述

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

输入

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

输出

The output should contain the minimum setup time in minutes, one per line.

样例输入

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

样例输出

2
1
3


先按照其中一个指标进行排序,然后再筛!!(从第一个开始,往后如果另一个指标都比这个大,那么就给个标记(也就是筛去了)。然后标记完了,又从第二个开始,筛过了就不用了,直接跳过,没有筛过就ans++。意思就是还有以这个打头的序列。)


#include <stdio.h>
#include <algorithm>
using namespace std;

struct stick
{
    int l,w;
    bool k;
}st[5005];

bool cmp(stick a,stick b)
{
    return a.l!=b.l?a.l<b.l:a.w<b.w;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int k,ans=0;
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
        {
            scanf("%d%d",&st[i].l,&st[i].w);
            st[i].k=false;
        }

        sort(st+1,st+1+k,cmp);
        for(int i=1;i<=k;i++)
        {
            if(!st[i].k)
            {
                st[i].k=true;
                ans++;
                int w=st[i].w;
                for(int j=i+1;j<=k;j++)
                {
                    if(!st[j].k&&st[j].w>=w)
                    {
                        st[j].k=true;
                        w=st[j].w;
                    }

                }
            }
        }
        printf("%d\n",ans);

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值