Apple Catching poj 2385(简单dp)

问题描述

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

输入

* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

输出

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

样例输入

7 2
2
1
1
2
2
1
1

样例输出


6    






我们令dp[i][j][m]表示第i分钟,跑了j次,当前在第m棵树的情况,那么就有

dp[i][j][1]=max(dp[i-1][j-1][2],dp[i-1][j][1])+(ma[i]==1?1:0);
dp[i][j][2]=max(dp[i-1][j-1][1],dp[i-1][j][2])+(ma[i]==2?1:0);
这个状态转移方程。但需要注意要初始化好跑了0次的情况,不然就会漏。
代码如下:
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int dp[1005][35][5];
int ma[1001];
int w;

int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        scanf("%d",&w);
        for(int i=1;i<=t;i++)
            scanf("%d",&ma[i]);
            for(int i=1;i<=t;i++)
            {
                    dp[i][0][1]=dp[i-1][0][1]+(ma[i]==1?1:0);
                    dp[i][0][2]=dp[i-1][0][2]+(ma[i]==2?1:0);
            }
        for(int i=1;i<=t;i++)
            for(int j=1;j<=w;j++)
            {

        
                dp[i][j][1]=max(dp[i-1][j-1][2],dp[i-1][j][1])+(ma[i]==1?1:0);
                dp[i][j][2]=max(dp[i-1][j-1][1],dp[i-1][j][2])+(ma[i]==2?1:0);

            }
        printf("%d\n",max(dp[t][w][1],dp[t][w][2]));
    }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值