Apple Catching (poj 2385 简单dp)

24 篇文章 0 订阅

Language:
Apple Catching
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8364 Accepted: 4094

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source


题意:有两棵苹果树,每一分钟其中一棵会掉一个苹果,给出T分钟内哪个树会掉苹果,人在两棵苹果树之间来回跑接苹果,问在最多跑W次下最多能接到多少苹果。

思路:转移方程:dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+count。dp[i][j]表示在第i分钟跑j次最多能接到的苹果数。count:当j为偶数时,人又跑回了1,此时count=(a[i]==1?1:0)即2-a[i];j为奇数时跑到了2,count=(a[i]==2?1:0)即a[i]-1.

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

int dp[maxn][33];
int a[maxn];
int t,w;

int main()
{
    int i,j;
    while (~sff(t,w))
    {
        mem(dp,0);
        FRE(i,1,t)
            sf(a[i]);
        FRE(i,1,t)
        {
            dp[i][0]=dp[i-1][0]+2-a[i];
            FRE(j,1,w)
            {
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);
                if (j%2)
                    dp[i][j]+=(a[i]-1);
                else
                    dp[i][j]+=(2-a[i]);
            }
        }
        int ans=-1;
        FRE(i,1,t)
            ans=max(ans,dp[i][w]);
        pf("%d\n",ans);
    }
    return 0;
}
/*
7 2
2
1
1
2
2
1
1
*/



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值