Cash Machine poj 1276(多重背包)

问题描述

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

输入

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

输出

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

样例输入

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

样例输出

735
630
0
0



多重背包,先是二进制优化版。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int dp[100002];int num[11],ma[11];

int main()
{
    int cash;int n;
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d %d",&num[i],&ma[i]);
            
        memset(dp,0,sizeof(dp));
        
        if(n==0||cash==0)
        {
            printf("0\n");
            continue;
        }
        
        for(int i=1;i<=n;i++)
        {
            if(num[i]*ma[i]>cash)//完全背包
            {
                for(int j=ma[i];j<=cash;j++)
                    dp[j]=max(dp[j],dp[j-ma[i]]+ma[i]);
            }
            else
            {
                int k=1,M=num[i];
                while(k<M)
                {
                    for(int j=cash;j>=k*ma[i];j--)
                        dp[j]=max(dp[j],dp[j-k*ma[i]]+k*ma[i]);
                    M-=k;
                    k*=2;
                }
                for(int j=cash;j>=M*ma[i];j--)
                    dp[j]=max(dp[j],dp[j-M*ma[i]]+M*ma[i]);
            }
        }
        printf("%d\n",dp[cash]);
    }
}


第二种就是时间为O(VN)版本

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int dp[100002];int used[100002];int num[11],ma[11];

int main()
{
    int cash;int n;
    while(scanf("%d%d",&cash,&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d %d",&num[i],&ma[i]);

        memset(dp,0,sizeof(dp));

        if(n==0||cash==0)
        {
            printf("0\n");
            continue;
        }

        dp[0]=1;
        for(int i=1;i<=n;i++)
        {
            memset(used,0,sizeof(used));
            for(int j=ma[i];j<=cash;j++)//一开始写成了 从1开始,wa了一发
            {
                if(!dp[j]&&dp[j-ma[i]]&&used[j-ma[i]]<num[i])
                {
                    dp[j]=1;
                    used[j]=used[j-ma[i]]+1;

                }
            }
        }
        for(int i=cash;i>=1;i--)
            if(dp[i])
        {
            printf("%d\n",i);
            break;
        }
            
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值