ZOJ Problem Set - 3946 Highway Project

Highway Project

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Di minutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ iN). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers N, M (1 ≤ N, M ≤ 105).

Then followed by M lines, each line contains four integers Xi, Yi, Di, Ci (0 ≤ Xi, Yi < N, 0 < Di, Ci < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input
2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2
Sample Output
4 3
4 4

一道裸的spfa。做题的时候没有将cost和i赋值为足够大,一直wa,烦死了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
using namespace std;
typedef long long LL;
const int N = 50005 * 5;
const LL INF = 100000000000;
struct Node
{
	LL v, c, d;
	int next;
}node[N];
int head[N];
int pos = 0;
LL cost[N], T[N];
bool inq[N];
void init()
{
	pos = 0;
	fill(cost, cost + N, INF);
	fill(T, T + N, INF);
	memset(inq, 0, sizeof(inq));
	memset(head, -1, sizeof(head));
}
void addEdge(int u, int v, int t, int c)
{//前向星
	node[pos].v = v;
	node[pos].c = c;
	node[pos].d = t;
	node[pos].next = head[u];
	head[u] = pos++;
}
void SPFA()
{
	queue<int> q;
	q.push(0);
	inq[0] = 1;
	cost[0] = 0;
	T[0] = 0;
	while (!q.empty())
	{
		int v = q.front();//循环到节点v
		q.pop();
		inq[v] = 0;
		for (int i = head[v]; i + 1; i = node[i].next)
		{
			int pos = node[i].v;//城市v能到达的城市
			if (T[v] + node[i].d <= T[pos])
			{
				if (T[v] + node[i].d < T[pos])
				{
					T[pos] = T[v] + node[i].d;
					cost[pos] = node[i].c;
					if (!inq[pos])
					{//城市pos是否在队列中
						inq[pos] = 1;
						q.push(pos);
					}
				}
				else if (cost[pos]>node[i].c)
				{
					cost[pos] = node[i].c;
					if (!inq[pos])
					{
						inq[pos] = 1;
						q.push(pos);
					}
				}
			}
		}
	}
}
int main()
{
	int t;
#ifdef glx
	freopen("in.txt", "r", stdin);
#endif
	scanf("%d", &t);
	while (t--)
	{
		int n, m;
		scanf("%d%d", &n, &m);
		int u, v, c, d;
		init();
		for (int i = 0; i < m; i++)
		{
			scanf("%d%d%d%d", &u, &v, &d, &c);
			addEdge(u, v, d, c);
			addEdge(v, u, d, c);
		}
		SPFA();
		LL dd = 0, cc = 0;
		for (int i = 0; i < n; i++)
		{
			dd += T[i];
			cc += cost[i];
		}
		printf("%lld %lld\n", dd, cc);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值