HDU 2070 迭代问题

HDU 2070 下面是这题的链接:
http://acm.hdu.edu.cn/showproblem.php?pid=2070
Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20978 Accepted Submission(s): 9777

Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.

Output
Print out the answer in a single line for each test case.

Sample Input
3
4
5
-1

Sample Output
2
3
5

Hint
Note:

you can use 64bit integer: __int64
这道题很简单,但是你用递归的话就不过,因为递归太慢了,这题得用迭代,然后从问题的底层出发
进行打表,打表的时候用long long 即可。

#include <iostream>//递归会溢出的~~
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std ;
int main()
{
    long long total, F[55];
    int n, m, i, j;
    F[0] = 0;
    F[1] = 1;
    for(i=2 ; i<=50 ; i++)
        F[i] = F[i-1] + F[i-2];
    while (~scanf("%lld", &n) && n != -1){
    cout << F[n] << endl;
    }
    return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值