HDU 1061 快速幂算法

HDU 1061 典型的快速幂题目,记住模板,题目的链接如下:
http://acm.hdu.edu.cn/showproblem.php?pid=1061

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47720 Accepted Submission(s): 18065

Problem Description
Given a positive integer N, you should output the most right digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the rightmost digit of N^N.

Sample Input
2
3
4

Sample Output
7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题目的大意就是,第一行是输出要测几个样例,然后每行就是x的x次方对10取余。这题用快速幂做才能ac,因为省了很多时间。

#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
//#define N 1000000
using namespace std ;
typedef long long LL;
LL fun(LL x, LL n)
{
    LL res = 1 ;
    while (n>0){
        if (n&1)
            res *= x % 10;
        x = (x*x)%10 ;
        n >>= 1;
    }
    return res ;
}
int main()
{
    LL n, a, total;
    cin >> n ;
    while (n--){
        cin >> a ;
        total = fun(a,a);
        cout << total%10 << endl ;
    }
return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值