POJ 2485 Highways 最小生成树

题目的链接如下:
http://poj.org/problem?id=2485

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28596 Accepted: 13040
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They’re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.
Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input

1

3
0 990 692
990 0 179
692 179 0
Sample Output

692
Hint

Huge input,scanf is recommended.

题目的大意就是找到最短路径中的最长的那一条要修建的路。

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cstdlib>
#include <stack>
#include <cstring>
#include <string>
#include <queue>
#define maxn 5000 + 10
#define INF 0x3f3f3f3f
using namespace std;
int father[maxn];
int cnt;
struct node
{
    int a,b,len;
}edge[maxn*maxn];

bool cmp(node a,node b)
{
    return a.len < b.len;
}

void make_set()
{
    for(int i = 0;i < maxn;++ i){
        father[i]=i;
    }
    return;
}

int Find(int x){//迭代版本
    int tempRoot;
    int root = x;
    while(root != father[root]) //找到根节点。
        root = father[root];
    while(x != root){
        tempRoot = father[x]; //x的父节点用临时变量存一下。
        father[x] = root; //x的父节点设置成根 (x 压缩到根节点了)
        x = tempRoot;   //x 赋值为 x的父节点(之前存过的);
    }
    return root; // 最后返回根节点
}
void Union(int x,int y){
    int xroot = Find(x);
    int yroot = Find(y);
    if(xroot == yroot) return;
    else{
        father[xroot]=yroot;
    }
}

int kruskal()
{
    int sum=0;
    make_set();
    sort(edge,edge+cnt,cmp);
    for(int i = 0;i < cnt;++ i){
        if(Find(edge[i].a)!=Find(edge[i].b)){
            Union(edge[i].a,edge[i].b);
            sum = max(sum,edge[i].len);
        }
    }
    return sum;
}

int main()
{
    int t, n, m;
    int res;
    int dis;

    //cin >> t;
    scanf("%d",&t);
    while(t--){
        cnt = 0;
        make_set();
        //cin >> n;
        scanf("%d", &n);
        for(int i = 0 ; i < n ; i++){
            for(int j = 0 ; j < n ; j++){
                //cin >> dis;
                // scanf("%d", &dis);
                if (scanf("%d", &dis) && i > j) {
                edge[cnt].a = i;
                edge[cnt].b = j;
                edge[cnt].len = dis;
                cnt++;
                }
            }
        }
        res = kruskal();
        //cout << res << endl;
        printf("%d\n", res);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值