题目链接如下点击打开链接
Prime Ring Problem
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 44254 Accepted Submission(s): 19613
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <stack>
//题目大意:一个素数环,然后任意两个数之间相加都是素数
int n ; //总共n个数字
int sum;//存每个dfs的总和;
int Case = 1;
//stack<int> a;//栈a用来存储要打印的东西
int a[25];//用数组来模拟栈;
int vis[25];//判断这个数字用没用过
int prime[50];//把50以内的素数打表
using namespace std;
void is_prime()//打印素数
{
int i,j;
for(i = 2 ; i < 8 ; i++)
if(!prime[i])
for(j = i*i ; j < 45 ; j += i)
prime[j] = 1;
}//0是素数
void print()//打印一个满足的路径
{
for(int i = 1 ; i <= n ; i++)
{
cout << a[i] ;
if(i != n) cout << ' ';
}
cout << endl;
}
void dfs(int step)//深搜
{
if(step == n+1 && !prime[a[n] + a[1]])//如果找了n个数了,而且第n个和第一个构成的也是素数则输出
{
print();
return ;
}
for(int i = 2 ; i <= n ; i++)
{
if(!vis[i] && !prime[i + a[step-1]])//它与上一个的和是素数,并且这个数没被用过
{
a[step] = i;
vis[i] = 1;
dfs(step+1);
vis[i] = 0;
}
}
}
int main()
{
is_prime();
while(cin >> n)
{
memset(vis, 0, sizeof(vis));
printf("Case %d:\n",Case++);
a[1] = 1;
vis[1] = 1;
dfs(2);
cout << endl;
}
return 0;
}