POJ - 3660 Cow Contest(Floyd)

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9807 Accepted: 5513

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

USACO 2008 January Silver

题意:有N头牛,每头牛都有自己的技能等级,技能等级高的一定能胜过等级低的,现在给出m个比赛结果,要求算出有几头牛的排名是能确定的
题解:Floyd算法,闭包的传递性:如果a<b且b<c,则a<c.因此,如果mp[i][j]==1或者mp[i][k]==1且mp[k][j]==1则说明i>j,最后计算比i等级高的个数与比i等级低的个数的和,如果cnt==n-1则说明i的排名是能确定的

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 1e2 + 5;
int mp[maxn][maxn],cnt[maxn];
int main(){
    int n,m;
    while(~scanf("%d%d",&n,&m)){
        memset(mp,0,sizeof(mp));
        memset(cnt,0,sizeof(cnt));
        for(int i=1;i<=n;i++) mp[i][i]=1;
        for(int i=0;i<m;i++){
            int u,v;
            scanf("%d%d",&u,&v);
            mp[u][v]=1;
        }
        for(int k=1;k<=n;k++){
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++){
                    mp[i][j]=(mp[i][j]==1)||(mp[i][k]&&mp[k][j]);  //如果i>j或者(i>k且k>j)就说明i>j
                }
            }
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                cnt[i]+=mp[i][j];
                cnt[j]+=mp[i][j];
            }
        }
        int ans=0;
        for(int i=1;i<=n;i++) if(cnt[i]==n+1) ans++;   //因为mp[i][i]会计算2次,所以是n+1
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值