POJ-3169 Layout(SPFA)

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10156 Accepted: 4891

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

USACO 2005 December Gold


题意:有N头牛按1~N的编号从左到右排成一排,其中有m对牛(A,B)是关系好的,它们之间的距离不能超过D,有k对牛(A,B)是关系不好的,它们之间的距离不能低于D,
牛可以站在同一个点(可以重合),输出1和N之间的最大距离是多少,如果这些牛不能排成一排则输出-1,如果距离是无穷大那么输出-2
题解:设d[i]为第i头牛离原点的距离.①对于关系好的牛(u,v),d[u]+D>=d[v],直接从u向v连一条权值为D的边;②对于关系不好的牛(u,v),d[u]+D<=d[v],变形为
d[v]+(-D)>=d[u],从v向u连一条权值为-D的边;③每头牛都可以重合(D==0),对于i∈[2,n],连一条i到i-1权值为0的边.
从1开始跑一边SPFA,如果有负圈表示牛之间的关系矛盾则输出-1(判断负圈的方法:如果一个点进入队列超过n次,那么一定有负圈)
笔记:最短路问题中,记从起点s出发,到各个顶点i的最短距离为d[i].因此对于每条权值为w的边e=(u,v),都有d[u]+w>=d[v]成立.反之,在满足全部这些约束不等式
的d中,d[v]-d[s]的最大值就是从s到v的最短距离.需要注意这里不是最小值,而是最大值对应着最短距离

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn_edge = 3e4 + 5;
const int maxn = 1e3 + 5;
struct Edge{
    int v,cost,nxt;
}edge[maxn_edge];
int d[maxn];
int head[maxn],tot,vis[maxn],IN[maxn];
void add(int u,int v,int cost){
    edge[tot].v=v;
    edge[tot].cost=cost;
    edge[tot].nxt=head[u];
    head[u]=tot++;
}
int main(){
    int n,m,k;
    while(~scanf("%d%d%d",&n,&m,&k)){
        tot=0;
        memset(d,0x3f,sizeof(d));
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(IN,0,sizeof(IN));
        int inf=d[0];
        for(int i=2;i<=n;i++) add(i,i-1,0);
        for(int i=0;i<m;i++){
            int u,v,cost;
            scanf("%d%d%d",&u,&v,&cost);
            add(u,v,cost);
        }
        for(int i=0;i<k;i++){
            int u,v,cost;
            scanf("%d%d%d",&u,&v,&cost);
            add(v,u,-cost);
        }

        d[1]=0;
        queue<int>q;
        q.push(1);
        vis[1]=1;
        bool flag=0;
        while(!q.empty()){
            if(flag) break;
            int u=q.front();q.pop();
            vis[u]=0;
            for(int i=head[u];~i;i=edge[i].nxt){
                int v=edge[i].v;
                if(d[v]>d[u]+edge[i].cost){
                    d[v]=d[u]+edge[i].cost;
                    if(!vis[v]){
                        vis[v]=1;
                        IN[v]++;
                        q.push(v);
                        if(IN[v]>n){
                            flag=1;
                            break;
                        }
                    }
                }
            }
        }
        if(flag) printf("-1\n");
        else if(d[n]==inf) printf("-2\n");
        else printf("%d\n",d[n]-d[1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值