HDU-5512 Pagodas(GCD+找规律)

Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 950    Accepted Submission(s): 676


Problem Description
n  pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from  1  to  n . However, only two of them (labelled  a and  b , where  1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled  i (i{a,b} and 1in)  if there exist two pagodas standing erect, labelled  j  and  k  respectively, such that  i=j+k  or  i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer  t (1t500)  which is the number of test cases.
For each test case, the first line provides the positive integer  n (2n20000)  and two different integers  a  and  b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
  
  
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
  
  
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
 

Source

传送门:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1005&ojid=0&cid=11108&hide=0

题意:有n个塔,编号为1~n,其中编号为a,b的塔已经是完美的,如果一个塔的编号k是某2个完美塔的编号相加或相减:k=i-j或k=i+j,那么这个塔就可以重建为完美塔,被重建为完美塔的塔不可以再次被重建.
现在Yuwgna和Iaka轮换重建这些塔,直到一个人不能重建塔则另一个人算获胜,问谁会获胜
题解:设gcd(a,b)=c,那么a=kc,b=pc,可以知道任何可以重建的塔的编号都会是c的倍数,因此只要找出n中有多少个数是c的倍数,再判断奇偶性就可以了


#include<cstdio>
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
int main(){
    int T,n,a,b;
   // freopen("in.txt","r",stdin);
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++){
        printf("Case #%d: ",cas);
        scanf("%d%d%d",&n,&a,&b);
        int k=gcd(a,b);
        printf("%s\n",(n/k)%2==1?"Yuwgna":"Iaka");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值