HDU 5512 Pagodas (扩展欧几里德)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5512


题面:

Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 593    Accepted Submission(s): 447


Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n . However, only two of them (labelled a and b , where 1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
  
  
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
  
  
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
 

Source
2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)


题意:
        很多人可能都是瞎猜的,或者是找规律吧。我也是,起初以为分是否有奇数两种情况即可,实际上数据较小的时候是最大公约数为1的特殊情况。
        此题用的是拓展欧基里德算法。
       扩展欧几里德算法是用来在已知a, b求解一组x,y,使它们满足贝祖等式: ax+by = gcd(a, b) =d(解一定存在,根据 数论中的相关定理)。扩展欧几里德常用在求解模 线性方程及方程组中。
      因此,实际问题转换为ka+jb=x,求x有解的数量,运用扩展欧基里德算法可得,求出ab最大公约数d(最小间距),随后用n/d,即得出可选的数量(实际上相当于把等式左边放大了若干倍),随后判断奇偶性即可。

代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include <algorithm>
using namespace std;
int map[55][55],dir[4][2]={-1,0,0,-1,1,0,0,1};
int main()
{
	int t,n,m,ans;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		memset(map,0,sizeof(map));
		scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
			   scanf("%d",&map[i][j]);
			   if(map[i][j])
				ans++;
			}
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				for(int k=0;k<4;k++)
				{
                   if(map[i][j]>map[i+dir[k][0]][j+dir[k][1]])
					   ans+=map[i][j]-map[i+dir[k][0]][j+dir[k][1]];
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值