HDU-2665 Kth number(主席树)

Kth number

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10810    Accepted Submission(s): 3317


Problem Description
Give you a sequence and ask you the kth big number of a inteval.
 

Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
 

Output
For each test case, output m lines. Each line contains the kth big number.
 

Sample Input
  
  
1 10 1 1 4 2 3 5 6 7 8 9 0 1 3 2
 

Sample Output
  
  
2
题意:m次询问,求区间[l,r]内第k大的数是多少

题解:裸主席树

#include<bits/stdc++.h>
using namespace std;
const int MX = 1e5 + 5;
int sum[MX*20],ls[MX*20],rs[MX*20],o[MX*20],tot;
int a[MX],b[MX],sz;
void build(int l,int r,int &rt){
    rt=++tot;
    sum[rt]=0;
    if(l==r) return;
    int m=(l+r)>>1;
    build(l,m,ls[rt]);
    build(m+1,r,rs[rt]);
}
void PushUP(int rt){
    sum[rt]=sum[ls[rt]]+sum[rs[rt]];
}
void update(int  p,int l,int r,int prt,int &rt){
    rt=++tot;
    if(l==r){
        sum[rt]=sum[prt]+1;
        return;
    }
    int m=(l+r)>>1;
    ls[rt]=ls[prt];rs[rt]=rs[prt];
    if(p<=m) update(p,l,m,ls[prt],ls[rt]);
    else update(p,m+1,r,rs[prt],rs[rt]);
    PushUP(rt);
}
//查询区间[l,r]内第k大的数
int query(int k,int l,int r,int prt,int rt){
    if(l==r) return l;
    int m=(l+r)>>1,cnt=sum[ls[rt]]-sum[ls[prt]];
    if(k<=cnt) return query(k,l,m,ls[prt],ls[rt]);
    return query(k-cnt,m+1,r,rs[prt],rs[rt]);
}
int main(){
    //freopen("in.txt","r",stdin);
    int T,n,m;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]),b[i]=a[i];
        sort(b+1,b+n+1);
        sz=unique(b+1,b+n+1)-b-1;
        tot=0;
        build(1,sz,o[0]);
        for(int i=1;i<=n;i++) a[i]=lower_bound(b+1,b+sz+1,a[i])-b;
        for(int i=1;i<=n;i++) update(a[i],1,sz,o[i-1],o[i]);
        while(m--){
            int l,r,k;
            scanf("%d%d%d",&l,&r,&k);
            printf("%d\n",b[query(k,1,sz,o[l-1],o[r])]);
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值