HDU - 2665[Kth number] 主席树裸题

Give you a sequence and ask you the kth big number of a inteval.
Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
s,t
s
t
indicates the interval and k indicates the kth big number in interval s,t
s
t
Output
For each test case, output m lines. Each line contains the kth big number.
Sample Input
1
10 1
1 4 2 3 5 6 7 8 9 0
1 3 2
Sample Output
2


题意:求区间第K大

solution: 主席树


#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 100007

int a[N], b[N], cnt[N*20], rt[N*20], rs[N*20], ls[N*20];
int n ,m, ql, qr, qk, sz, tot;

void build( int &o, int l, int r ){
    o = ++tot;
    cnt[o] = 0;
    if ( l == r ) return ;
    int mid = ( l + r ) >> 1;
    build( ls[o], l, mid), build( rs[o], mid+1, r);
}

void update( int &o, int l, int r, int last, int p){
    o = ++tot;
    ls[o] = ls[last];
    rs[o] = rs[last];
    cnt[o] = cnt[last] + 1;
    if ( l == r ) return ;
    int mid = ( l + r ) >> 1;
    if ( p <= mid ) update( ls[o], l, mid, ls[last], p);
    else update( rs[o], mid+1, r, rs[last], p );
}

int query( int s, int t, int l, int r, int k){
    if ( l == r ) return l;
    int mid = ( l + r ) >> 1;
    int ans = cnt[ls[t]] - cnt[ls[s]];
    if ( k <= ans ) return query( ls[s], ls[t], l, mid, k);
    else return query( rs[s], rs[t], mid+1, r, k-ans);
}

void work(){
    scanf( "%d%d%d", &ql, &qr, &qk);
    printf( "%d\n", b[query( rt[ql-1], rt[qr], 1, sz, qk)] );
}

int main(){
    int T;
    scanf( "%d", &T);
    while ( T-- ){
        scanf( "%d%d", &n, &m );
        for ( int i = 1; i <= n; i++) scanf( "%d", &a[i] ), b[i] = a[i];
        sort( b+1, b+1+n );
        sz = unique( b+1, b+1+n ) - (b+1);
        tot = 0;
        build( rt[0], 1, sz);
        for ( int i = 1; i <= n; i++) a[i] = lower_bound( b+1, b+1+sz, a[i]) - b;
        for ( int i = 1; i <= n; i++) update( rt[i], 1, sz, rt[i-1], a[i]);
        while ( m-- ) work();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
CSDN IT狂飙上传的代码均可运行,功能ok的情况下才上传的,直接替换数据即可使用,小白也能轻松上手 【资源说明】 基于MATLAB实现的有限差分法实验报告用MATLAB中的有限差分法计算槽内电位;对比解析法和数值法的异同点;选取一点,绘制收敛曲线;总的三维电位图+使用说明文档 1、代码压缩包内容 主函数:main.m; 调用函数:其他m文件;无需运行 运行结果效果图; 2、代码运行版本 Matlab 2020b;若运行有误,根据提示GPT修改;若不会,私信博主(问题描述要详细); 3、运行操作步骤 步骤一:将所有文件放到Matlab的当前文件夹中; 步骤二:双击打开main.m文件; 步骤三:点击运行,等程序运行完得到结果; 4、仿真咨询 如需其他服务,可后台私信博主; 4.1 期刊或参考文献复现 4.2 Matlab程序定制 4.3 科研合作 功率谱估计: 故障诊断分析: 雷达通信:雷达LFM、MIMO、成像、定位、干扰、检测、信号分析、脉冲压缩 滤波估计:SOC估计 目标定位:WSN定位、滤波跟踪、目标定位 生物电信号:肌电信号EMG、脑电信号EEG、心电信号ECG 通信系统:DOA估计、编码译码、变分模态分解、管道泄漏、滤波器、数字信号处理+传输+分析+去噪、数字信号调制、误码率、信号估计、DTMF、信号检测识别融合、LEACH协议、信号检测、水声通信 5、欢迎下载,沟通交流,互相学习,共同进步!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值