HDU - 2665[Kth number] 主席树裸题

Give you a sequence and ask you the kth big number of a inteval.
Input
The first line is the number of the test cases.
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere.
The second line contains n integers, describe the sequence.
Each of following m lines contains three integers s, t, k.
s,t
s
t
indicates the interval and k indicates the kth big number in interval s,t
s
t
Output
For each test case, output m lines. Each line contains the kth big number.
Sample Input
1
10 1
1 4 2 3 5 6 7 8 9 0
1 3 2
Sample Output
2


题意:求区间第K大

solution: 主席树


#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

#define N 100007

int a[N], b[N], cnt[N*20], rt[N*20], rs[N*20], ls[N*20];
int n ,m, ql, qr, qk, sz, tot;

void build( int &o, int l, int r ){
    o = ++tot;
    cnt[o] = 0;
    if ( l == r ) return ;
    int mid = ( l + r ) >> 1;
    build( ls[o], l, mid), build( rs[o], mid+1, r);
}

void update( int &o, int l, int r, int last, int p){
    o = ++tot;
    ls[o] = ls[last];
    rs[o] = rs[last];
    cnt[o] = cnt[last] + 1;
    if ( l == r ) return ;
    int mid = ( l + r ) >> 1;
    if ( p <= mid ) update( ls[o], l, mid, ls[last], p);
    else update( rs[o], mid+1, r, rs[last], p );
}

int query( int s, int t, int l, int r, int k){
    if ( l == r ) return l;
    int mid = ( l + r ) >> 1;
    int ans = cnt[ls[t]] - cnt[ls[s]];
    if ( k <= ans ) return query( ls[s], ls[t], l, mid, k);
    else return query( rs[s], rs[t], mid+1, r, k-ans);
}

void work(){
    scanf( "%d%d%d", &ql, &qr, &qk);
    printf( "%d\n", b[query( rt[ql-1], rt[qr], 1, sz, qk)] );
}

int main(){
    int T;
    scanf( "%d", &T);
    while ( T-- ){
        scanf( "%d%d", &n, &m );
        for ( int i = 1; i <= n; i++) scanf( "%d", &a[i] ), b[i] = a[i];
        sort( b+1, b+1+n );
        sz = unique( b+1, b+1+n ) - (b+1);
        tot = 0;
        build( rt[0], 1, sz);
        for ( int i = 1; i <= n; i++) a[i] = lower_bound( b+1, b+1+sz, a[i]) - b;
        for ( int i = 1; i <= n; i++) update( rt[i], 1, sz, rt[i-1], a[i]);
        while ( m-- ) work();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值