D-City(并查集)

原题链接
D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3694 Accepted Submission(s): 1319

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

//题意:给定一个图,N个点,M条边,先把给定的M个连成图,然后反过来从第1个开始顺序到M个删边后剩下的多少联通块。
//思路:其实我们可以逆向思考,从第M个开始,到第一个依次加边,这样就是相当于简单的并查集了;
#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int maxn=100000  + 5;

struct node{
        int x,y;
}a[maxn];
int res[maxn];
int f[10005];
int find(int x){
        if(f[x]==x) return x;
        else{
                f[x]=find(f[x]);
                return f[x];
        }
}
int main(){
        int n,m;
        while(scanf("%d%d",&n,&m)==2){
                for(int i=1;i<=m;i++)
                        scanf("%d%d",&a[i].x,&a[i].y);
                memset(res,0,sizeof(res));
                memset(f,0,sizeof(f));
                for(int i=0;i<=n;i++)
                        f[i]=i;//在并查集的刚开始的时候一般他的父亲都是自己
                res[m]=n;
                for(int i=m;i>1;i--){
                        int px=find(a[i].x);
                        int py=find(a[i].y);
                        if(px!=py){//当他们的父亲不相同时,就说明他们不是同一个连通块的
                                f[px]=py;
                                res[i-1]=res[i]-1;
                        }
                        else{
                                res[i-1]=res[i];
                        }
                }
                for(int i=1;i<=m;i++)
                        printf("%d\n",res[i]);
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
SELECT th.id hotelId, th.hotel_name hotelName, th.country_name countryName, th.city_name cityName, th.active, d.supplyclass as supplyClass, if(ISNULL(a.sort_rank),1000,a.sort_rank) sort FROM t_baseinfo_hotel th LEFT JOIN (SELECT * FROM t_baseinfo_hotel_sort ths WHERE ths.org_code = #{orgCode})a ON a.hotel_id = th.id LEFT JOIN (SELECT hotel_id,GROUP_CONCAT(supplyclass) supplyclass from t_supply_hotel_mapping where 1=1 <if test="hotelId != null and hotelId != ''"> AND hotel_id = #{hotelId} </if> <if test="hotelIds != null and hotelIds != ''"> AND hotel_id IN <foreach item="item" index="index" collection="hotelIds.split(',')" open="(" separator="," close=")"> #{item} </foreach> </if> <if test="supplierCodes != null and supplierCodes != ''"> AND supplyclass IN <foreach item="item" index="index" collection="supplierCodes.split(',')" open="(" separator="," close=")"> #{item} </foreach> </if> GROUP BY hotel_id ) d on th.id =d.hotel_id WHERE th.deleted = 0 <if test="cityCode != null and cityCode != ''"> AND th.city_code = #{cityCode} </if> <if test="hotelId != null and hotelId != ''"> AND th.id = #{hotelId} </if> <if test="null != hotelName and hotelName != ''"> AND th.hotel_name LIKE "%"#{hotelName}"%" </if> <if test="active != null and active == 1"> AND th.active = 1 </if> <if test="hotelIds != null and hotelIds != ''"> AND th.id IN <foreach item="item" index="index" collection="hotelIds.split(',')" open="(" separator="," close=")"> #{item} </foreach> </if> <if test="supplierCodes != null and supplierCodes != ''"> AND th.id =d.hotel_id </if> ORDER BY sort ASC,th.id DESC
06-09

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值