hdu 4496 D-City 并查集

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2317    Accepted Submission(s): 814


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.


链接:http://acm.hdu.edu.cn/showproblem.php?pid=4496


题意:给你 n个点 m条边,首先边是都建好了的。 然后删一条边,然后问你当前图里有几个团。


做法:倒着做,起始5个点 ,5个团,每次先输出几个团。 然后开始并那两个给出的点,用并查集,然后find找到的祖先如果不同,那么就是有两个团并掉了。就把总的团数-1。 如果两个点 find 返回值相同 就是这两个点本来就是在一个团里的,就不用处理。每次先输出当前有几团再并。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
#define INF 999999999
#define eps 0.00001
#define LL __int64d
#define pi acos(-1.0)

int n,m;
int lian[100010][2];
int f[10010];
int find(int x){return x==f[x]?x:f[x] = find(f[x]);}  //初始化为自己
int Union(int x, int y){
	int fx = find(x), fy = find(y);
	if(fx == fy) 
		return 0;
	if(fx>fy)
		swap(fx,fy);
	f[fx] = f[x] = f[y] = fy;
	return 1;
}
int ans[100010];

int main()
{ 
	while(scanf("%d%d",&n,&m)!=EOF){
		for(int i=0;i<n;i++)
		{
			f[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&lian[i][0],&lian[i][1]);
		}
		int nw=n;
		for(int i=m-1;i>=0;i--)
		{
			int tem=Union(lian[i][0],lian[i][1]);
			ans[i]=nw;
			if(tem) 
				nw--; 
		}
		for(int i=0;i<m;i++)
		 printf("%d\n",ans[i]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值