Prime Path(素数筛+BFS)

原题链接
Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17661 Accepted: 9948
Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on… Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit
(without leading zeros).
Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input

3
1033 8179
1373 8017
1033 1033
Sample Output

6
7
0
Source

Northwestern Europe 2006

//http://poj.org/problem?id=3126
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;

typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = (~(0ULL)>>1);
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=10000 + 5;
bool is_prime[maxn];
int vis[maxn];
const int digit[4]={1000,100,10,1};
int l,r;
void prime(){
        memset(is_prime,true,sizeof(is_prime));//true代表是质数
        is_prime[0]=is_prime[1]=false;
        for(int i=2;i<maxn;i++){
                if(is_prime[i]){
                        for(int j=i*2;j<maxn;j+=i)
                                is_prime[j]=false;
                }
        }
        return;
}
bool can(int x){
        if(!is_prime[x] || vis[x]!=-1) return false;
        else return true;
}
void BFS(int x){
        memset(vis,-1,sizeof(vis));
        queue<int> que;
        que.push(x);
        vis[x]=0;
        while(!que.empty()){
                int nowx=que.front();
                int tx=nowx;//tx是用来保存当前的这个数
                que.pop();
                for(int i=3;i>=0;i--){
                        int nowdigit=nowx%10;
                        nowx/=10;
                        if(i!=0){
                                for(int j=0;j<10;j++){
                                        if(j==nowdigit) continue;
                                        int newx=(tx - nowdigit*digit[i] + j*digit[i]);
                                        if(can(newx)){
                                                vis[newx]=vis[tx]+1;
                                                if(newx==r) return;
                                                que.push(newx);
                                        }
                                }
                        }
                        else{//此时列举首位
                                for(int j=1;j<10;j++){
                                        if(j==nowdigit) continue;
                                        int newx=(tx - nowdigit*digit[i] + j*digit[i]);
                                        if(can(newx)){
                                                vis[newx]=vis[tx]+1;
                                                if(newx==r) return;
                                                que.push(newx);
                                        }
                                }
                        }
                }
        }
        return;
}
int main(){
        int T;cin >> T;
        prime();
        while(T--){
                scanf("%d%d",&l,&r);
                BFS(l);
                if(vis[r]==-1) printf("Impossible\n");
                else printf("%d\n",vis[r]);
        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值