POJ1222-EXTENDED LIGHTS OUT-反转

原题链接
EXTENDED LIGHTS OUT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9955 Accepted: 6434
Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:

  1. It does not matter what order the buttons are pressed.
  2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
  3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
    four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
    Write a program to solve the puzzle.
    Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.
Output

For each puzzle, the output consists of a line with the string: “PUZZLE #m”, where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1’s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.
Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0
Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1
Source

Greater New York 2002
题意:开关灯,每个开关都可以控制自己和上下左右的区域从暗到亮或者是从亮到暗,求出使所有灯都变暗的方法
思路:枚举第一排灯所有可能的操作,然后通过下一行的控制来似的这一行的所有灯都关闭,如果最后一行刚好全部关闭就说明成功了

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int a[6][8],f[6][8],n;
bool solve(){
	for(int i=2;i<=5;i++)
		for(int j=1;j<=6;j++)
			f[i][j] = (a[i-1][j]+f[i-1][j]+f[i-2][j]+f[i-1][j-1]+f[i-1][j+1])&1 ? 1 : 0;
	for(int j=1;j<=6;j++)
		if((a[5][j]+f[5][j]+f[4][j]+f[5][j-1]+f[5][j+1])&1) return false;
	return true;
}
int main(){
	cin >> n;
	for(int k=1;k<=n;k++){
		for(int i=1;i<=5;i++)
			for(int j=1;j<=6;j++)
				scanf("%d",&a[i][j]);
		cout << "PUZZLE #" << k << endl;
		for(int i=0;i<64;i++){
			memset(f,0,sizeof(f));
			for(int j=0;j<6;j++) f[1][j+1] = i>>j & 1;
			if(solve()) break;
		}
		for(int i=1;i<=5;i++){
			for(int j=1;j<6;j++){
				printf("%d ",f[i][j]);
			}
			printf("%d\n",f[i][6]);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值