POJ3616-Milking Time-区间动态规划

原题链接
Milking Time
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8764 Accepted: 3647
Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output

43
Source

USACO 2007 November Silver

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1e6 + 10;
const int maxm = 1e3 + 10;
typedef long long ll;
typedef struct sec
{
	int s,e;
	ll v;
}sec;
sec a[maxm];
ll dp[maxn];
bool cmp(sec x,sec y){
	return x.e < y.e;
}
int main(){
	int n,m,r;
	scanf("%d%d%d",&n,&m,&r);
	for(int i=0;i<m;i++)
		scanf("%d%d%lld",&a[i].s,&a[i].e,&a[i].v);
	sort(a,a+m,cmp);
	for(int i=0;i<m;i++){
		int e=a[i].e,s=a[i].s;
		dp[e]=max(dp[e],dp[e-1]);//顺延的情况
		if(s-r<=0) dp[e]=max(dp[e],a[i].v);//由上个可用的时间转移过来
		else dp[e]=max(dp[e],dp[s-r]+a[i].v);
		fill(dp+e,dp+n+1,dp[e]);
		// for(int j=0;j<=n;j++) cout << dp[j] << " ";
		// cout << endl;
	}
	cout << dp[n] <<endl;
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值