HDOJ 2492 Ping pong(BIT的应用)

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5280    Accepted Submission(s): 1951


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). 

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

Sample Input
  
  
1 3 1 2 3
 

Sample Output
  
  
1
一开始想不通怎样用树状数组下手,后来参考了一下别人的代码,发现是用树状数组来确定每个点的左边右边有多少个比它小的数,就是从确定裁判的位置入手解决问题。
#include <iostream>
#include <string.h>
#define ll long long
using namespace std;
const int MAX_N=100005;
int BIT[MAX_N],num[MAX_N],c[MAX_N],d;//c,d用来表示裁判 
ll cnt;
int lowbit(int x)
{
	return x&-x;
}
void add(int x)
{
	while(x<=MAX_N)
	{
		BIT[x]++;
		x+=lowbit(x);
	}
	return;
}
ll sum(int k)
{
	ll ans=0;
	while(k)
	{
		ans+=BIT[k];
		k-=lowbit(k);
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		cnt=0;
		int n;
		scanf("%d",&n);
		memset(BIT,0,sizeof(BIT));
		for(int i=0;i<n;i++)//c[i]从左往右插入,sum得到的是左边比它小的数 
		{
			scanf("%d",&num[i]);
			add(num[i]);
			c[i]=sum(num[i]-1);
		}
		memset(BIT,0,sizeof(BIT));
		for(int i=n-1;i>=0;i--)//d得到的是在从左往右插入时右边比它小的数 
		{
			add(num[i]);
			d=sum(num[i]-1);
			//cout<<i<<" "<<d<<" "<<c[i]<<" ";
			//(n-1-i-d)表示比c大, (i-c[i])表示比c大,可以想象为1,0,-1或-1,0,1的模型,中间点位于两者之间 
			cnt+=c[i]*(n-1-i-d)+(i-c[i])*d;
			//cout<<cnt<<endl;
		}
		printf("%lld\n",cnt);
	}
	return 0;
}

差不多就这样子,最后贴上一个介绍树状数组的博客,写得很好
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值