HDOJ 1075 What Are You Talking About(map入门)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 7414    Accepted Submission(s): 2292


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

 

Output
In this problem, you have to output the translation of the history book.
 

 

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 

 

Sample Output

hello, i'm from mars. i like earth!

菜到连STL都不会了,勤恳忙活,日子久了,所谓的还击不过是狡黠一笑。

#include <iostream>
#include <map>
#include <string.h> 
using namespace std;
map<string,string>M;//前面string为key,后面是value,就比如a[i],i就是key,里面存储的就是value 
int main()
{
	//freopen("input.txt","r",stdin);
	string a,b;
	cin>>a;//吃START 
	while(cin>>a&&a!="END")
	{
		cin>>b;
		M[b]=a;//用map记录字典 
	}
	cin>>a;//吃START 
	getchar();//吃一个回车,不然下面temp就是回车了 
	char temp[3005];
	while(true)
	{
		gets(temp);//听说gets比getline强 
		if(strcmp(temp,"END")==0)
			break;
		int len=strlen(temp);
		b="";
		for(int i=0;i<len;i++)
		{
			if(temp[i]>='a'&&temp[i]<='z')//保证temp[i]不为符号或空格 
			{
				b+=temp[i];
			}
			else
			{
				if(M[b]!="")//表明b有对应的翻译 
					cout<<M[b];//输出翻译 
				else
					cout<<b;//没有对应翻译的时候输出原文 
				b="";//重置b 
				cout<<temp[i];//注意,不仅要输出b(或b的翻译) 
			}
		}
		cout<<endl;
	}
	return 0;	
}
前几天的天梯赛打得抠脚,日子看起来有序罢了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值