poj3080

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16211 Accepted: 7212

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题意:求n个字符串的最长公共串。

求n个字符长度最长公共子串。对于多模式匹配问题,一般是不可以用KMP解决得,因为忒暴力。

思路很简单:我们先按字符串的长度由短到长进行快排。枚举第一个字符串的不同长度子串,判断她是否为下面多有的公共子串?如果是的话,那么我们就表明找到,则比较其长度,如果比已经找到的串长,那么就替换结果串 否则按字典序比较。取字典序考前的,就可以

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<malloc.h>
#include<math.h>
char s[10][62];
char p[62];
int next[62];
int plen;
int n;
int ma;
int ans;
char result[62];
void getnext(){
    int j=0;
    int k=-1;
    next[0]=-1;
    while(j<plen-1){
        if(k==-1||p[j]==p[k]){
            ++k;
            ++j;
            if(p[j]!=p[k]){
                next[j]=k;
            }
            else
                next[j]=next[k];
        }
        else{
            k=next[k];
        }
    }
}
void kmp(){
    getnext();
    ma=100;
    int i,j,m;
    int k;
    for(k=1;k<n;k++){
        i=0;j=0;m=0;
        while(i<60&&j<plen){
            if(j==-1||s[k][i]==p[j]){
                i++;
                j++;
            }
            else{
                j=next[j];
            }
            if(j>m)m=j;
        }
        if(ma>m)ma=m;
    }
}
int main(){
    int kase;
    scanf("%d",&kase);
    int i;
    while(kase--){
        ans=0;
        scanf("%d",&n);
        for(i=0;i<n;i++){
            scanf("%s",s[i]);
        }
        for(i=0;i<57;i++){
            strcpy(p,s[0]+i);
            plen=60-i;
            kmp();
            if(ans<ma){
                ans=ma;
                strncpy(result,s[0]+i,ans);
                result[ans]='\0';
            }
            else if(ans==ma){
                char tm[62];
                strncpy(tm,s[0]+i,ans);
                tm[ans]='\0';
                if(strcmp(tm,result)<0)
                    strcpy(result,tm);
            }
        }
        if(ans>=3){
            printf("%s\n",result);
        }
        else{
            printf("no significant commonalities\n");
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值