求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
Input
 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 
Output
 输出二叉树的先序遍历序列
Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
abdegcf
xnliu


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
    char date;
    struct node *lchild, *rchild;
};
struct node *creat(char *a, char *b, int n)
{
    char *p;
    struct node *ptr = (struct node *)malloc(sizeof(struct node));
    if(n <= 0)
    return NULL;
    ptr -> date = *(b + n - 1);
    int k = 0;
    for(p = a; *p != '\0'; p++)
    {
        if(*p == *(b + n - 1))break;
    }
    k = p - a;
    ptr -> lchild = creat(a, b, k);
    ptr -> rchild = creat(a + k + 1, b + k, n - k - 1);
    return ptr;
}
void qian(struct node *T)
{
    if(T)
    {
        printf("%c", T -> date);
        qian(T -> lchild);
        qian(T -> rchild);
    }
}
int main()
{
    int t;
    char a[60], b[60];
    struct node *T;
    scanf("%d", &t);
    int n;
    while(t--)
    {
        scanf("%s%s", a, b);
        n = strlen(b);
        T = creat(a, b, n);
        qian(T);
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值