数据结构实验之链表七:单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Example Input
10
21 30 14 55 32 63 11 30 55 30
Example Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
#include<stdio.h>
#include<malloc.h>
struct node
{
    int date;
    struct node *next;
};
struct node * creat(int n)
{
    struct node *head, * p;
    int i;
    head = (struct node *)malloc(sizeof(struct node));
    head -> next = NULL;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p -> date);
        p -> next = head -> next;
        head -> next = p;
    }
    return (head);
}
int main()
{
    int n;
    struct node *head, *p, *t, *q;
    scanf("%d", &n);
    head = creat(n);
    q = head -> next;
    printf("%d\n", n);
    for(p = head -> next; p != NULL; p = p -> next)
    {
        if(p == head -> next)
        {
            printf("%d", p -> date);
        }
        else
        {
            printf(" %d", p -> date);
        }
    }
    printf("\n");
    while(q)
    {
        t = q;
        p = q -> next;
        while(p)
        {
            if(q -> date == p -> date)
            {
                t -> next = p -> next;
                n--;
                p = p -> next;
            }
            else
            {
                t = t -> next;
                p = p -> next;
            }
        }
        q = q -> next;
    }
    printf("%d\n", n);
    for(p = head -> next; p != NULL; p = p -> next)
    {
        if(p == head -> next)
        {
            printf("%d", p -> date);
        }
        else
        {
            printf(" %d", p -> date);
        }
    }
    printf("\n");
    return 0;
}

/***************************************************
User name: jk170704***
Result: Accepted
Take time: 0ms
Take Memory: 148KB
Submit time: 2018-01-19 14:16:41
****************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值