数据结构实验之链表四:有序链表的归并

Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100
Hint
不得使用数组!
 
 
 
 
#include<stdio.h>
#include<stdlib.h>
struct node
{
    int date;
    struct node *next;
};
int main()
{
    int i, m, n;
    scanf("%d%d", &m, &n);
    struct node *head, *head1, *p, *q, *tail, *head2, *q1;
    head = (struct node *)malloc(sizeof(struct node));
    head1 = (struct node *)malloc(sizeof(struct node));
    head -> next = NULL;
    head1 -> next = NULL;
    tail = head;
    for(i = 1; i <= m; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p -> date);
        p -> next = tail -> next;
        tail -> next = p;
        tail = p;
    }
    tail = head1;
    for(i = 1; i <= n; i++)
    {
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d", &p -> date);
        p -> next = tail -> next;
        tail -> next = p;
        tail = p;
    }
    q1 = head -> next;
    q = head1 -> next;
    head2 = (struct node*)malloc(sizeof(struct node));
    head2 -> next = NULL;
    tail = head2;
   // printf("  %d  ", q1 -> date);
    while(q1 && q)
    {
        if(q1 -> date <= q -> date)
        {
            //q1 -> next = tail -> next;
            tail -> next = q1;
            tail = q1;
            q1 = q1 -> next;
            //printf("  %d  ", q1 -> date);
        }
        else//if(p -> date > q -> date)
        {
            //q -> next = tail -> next;
            tail -> next = q;
            tail = q;
            q = q -> next;
        }
    }
    if(q1)
    {
        tail -> next = q1;
    }
    else if(q)
    {
        tail -> next = q;
    }
    p = head2 -> next;
    while(p)
    {
        if(p == head2 -> next)
        {
            printf("%d", p -> date);
        }
        else
        {
            printf(" %d", p -> date);
        }
        p = p -> next;
    }
    printf("\n");
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值