数据结构实验之查找七:线性之哈希表

数据结构实验之查找七:线性之哈希表

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

根据给定的一系列整数关键字和素数p,用除留余数法定义hash函数H(Key)=Key%p,将关键字映射到长度为p的哈希表中,用线性探测法解决冲突。重复关键字放在hash表中的同一位置。

Input

连续输入多组数据,每组输入数据第一行为两个正整数N(N <= 1500)和p(p >= N的最小素数),N是关键字总数,p是hash表长度,第2行给出N个正整数关键字,数字间以空格间隔。

Output

输出每个关键字在hash表中的位置,以空格间隔。注意最后一个数字后面不要有空格。

Sample Input
5 5
21 21 21 21 21
4 5
24 15 61 88
4 5
24 39 61 15
5 5
24 39 61 15 39
Sample Output
1 1 1 1 1
4 0 1 3
4 0 1 2
4 0 1 2 0
Hint


Source
//根据题意构造探测函数 然后循环探测
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int dis[1600];
int Hash[1600];///主要是检测该点是否出现过
int locate[1600];///储存

int main()
{
    int key;
    int k;
    int n,m;
    //int cnt = 1;
    dis[0] = 0;
    for(int i = 1; i< 1600; i++) ///构造线性探测函数
    {
        dis[i] = i;
    }
    while(~scanf("%d%d",&n,&m))
    {
        memset(Hash,-1,sizeof(Hash));
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&key);
            for(int j = 0; j <= 1500; j++)
            {
                k = ((key%m) + dis[j]) %m;
                if(Hash[k] == -1) ///如果该地址还没有储存
                {
                    Hash[k] = key;
                    locate[i] = k;
                    break;
                }
                else if(Hash[k] == key) ///已经储存了该数字,直接记录位置
                {
                    locate[i] = k;
                    break;
                }
                 ///二次探测再散列
            }
        }
        int flag = 1;
        for(int i = 0; i < n; i++)
        {
            if(flag)
            {
                printf("%d",locate[i]);
                flag = 0;
            }
            else
                printf(" %d",locate[i]);
        }
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值