甲级1006 Sign In and Sign Out

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目的大概意思就是说每天最早来的人开门,最晚走的人关门,给定每天来的人的编号与进入离开的时间,让我们求出每天开门的和关门的人输出他们的编号,以空格隔开。 题目很简单,只要注意到输入的时间是以24小时制的,可以直接用String的compare方法比较时间。

package advanced.ab1006;



import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
public class Main {
    public static void main(String[] args)  {
        Scanner sc = new Scanner(System.in);
        int count = sc.nextInt();
        List<String[]> list = new ArrayList<>();//不需要用集合,只要用数组存储就行,数组效率更高
       while(sc.hasNext()){
           String [] str = new String[3];
           int i = 0;
           str[i] = sc.next();
           i++;
           str[i] = sc.next();
           i++;
           str[i] = sc.next();
           if (i==2){
               i = 0;
               list.add(str);
           }
       }
       String early = list.get(0)[0];
       String earlyDate = list.get(0)[1];
       String late = list.get(0)[0];
       String lateDate = list.get(0)[2];
           for(int i=0;i<list.size();i++){
              if(earlyDate.compareTo(list.get(i)[1])>0){
                  earlyDate = list.get(i)[1];
                  early = list.get(i)[0];
              }
              if (lateDate.compareTo(list.get(i)[2])<0){
                  lateDate = list.get(i)[2];
                  late = list.get(i)[0];
              }
           }
           System.out.println(early+" "+late);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值