PAT 甲级 1006 Sign In and Sign Out

PAT 甲级 1006 Sign In and Sign Out

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
结尾无空行

Sample Output:

SC3021234 CS301133
结尾无空行
题意描述:

给定N个人的名字以及开始和结束的时间,求最早开始以及最晚结束的人的名字。

解题思路:

本题的唯一难点在于时间的比较大小,由于题目给的时间是24小时制,因此可以计算每一个时间对应到多少秒,例如15:30:28对应的就是15×3600+30×60+28秒,后面就是常规的最值比较问题了。

难度评测:Easy
AC代码实现:
#include <bits/stdc++.h>
using namespace std;
string name[1005];

int main()
{
	int m, sh, sm, ss, eh, em, es, st, et;
	int ids, ide;
	int S = 86400, E = 0;
	cin >> m;
	for(int i = 0; i < m; i++) {
		cin >> name[i];
		scanf("%d:%d:%d %d:%d:%d", &sh, &sm, &ss, &eh, &em, &es);
		st = sh * 3600 + sm * 60 + ss;
		et = eh * 3600 + em * 60 + es;
		if(st < S) {
			S = st;
			ids = i;
		}
		if(et > E) {
			E = et;
			ide = i;
		}
	}
	cout << name[ids] << " " << name[ide];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值