2017 Multi-University Training Contest - Team 7:hdu6124、Euler theorem

题目:

Problem Description
HazelFan is given two positive integers a,b , and he wants to calculate amodb . But now he forgets the value of b and only remember the value of a , please tell him the number of different possible results.
 

Input
The first line contains a positive integer T(1T5) , denoting the number of test cases.
For each test case:
A single line contains a positive integer a(1a109) .
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 1 3
 

Sample Output
  
  
2 3
题意:求a%b有多少种结果,已知a,不知道b

思路:打表找规律,很容易看出如果a是奇数的话,答案是(奇数+1)/2+1;a是偶数的话,答案是a/2+1

code:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        int t,a;
        scanf("%d",&t);
        while(t--){
                scanf("%d",&a);
                if(a%2) a++;
                printf("%d\n",a/2+1);
        }
        return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值