2017 Multi-University Training Contest - Team 8 :1011&hdu6143、Killer Names

题目:

Killer Names

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1104    Accepted Submission(s): 543


Problem Description
> Galen Marek, codenamed Starkiller, was a male Human apprentice of the Sith Lord Darth Vader. A powerful Force-user who lived during the era of the Galactic Empire, Marek originated from the Wookiee home planet of Kashyyyk as the sole offspring of two Jedi Knights—Mallie and Kento Marek—who deserted the Jedi Order during the Clone Wars. Following the death of his mother, the young Marek's father was killed in battle by Darth Vader. Though only a child, Marek possessed an exceptionally strong connection to the Force that the Dark Lord of the Sith sought to exploit.
>
> When Marek died in 2 BBY, shortly after the formation of the Alliance, Vader endeavored to recreate his disciple by utilizing the cloning technologies of the planet Kamino. The accelerated cloning process—an enhanced version of the Kaminoan method which allowed for a rapid growth rate within its subjects—was initially imperfect and many clones were too unstable to take Marek's place as the Dark Lord's new apprentice. After months of failure, one particular clone impressed Vader enough for him to hope that this version might become the first success. But as with the others, he inherited Marek's power and skills at the cost of receiving his emotions as well, a side effect of memory flashes used in the training process.
>
> — Wookieepedia

Darth Vader is finally able to stably clone the most powerful soilder in the galaxy: the Starkiller. It is the time of the final strike to destroy the Jedi remnants hidden in every corner of the galaxy.

However, as the clone army is growing, giving them names becomes a trouble. A clone of Starkiller will be given a two-word name, a first name and a last name. Both the first name and the last name have exactly n characters, while each character is chosen from an alphabet of size m . It appears that there are m2n possible names to be used.

Though the clone process succeeded, the moods of Starkiller clones seem not quite stable. Once an unsatisfactory name is given, a clone will become unstable and will try to fight against his own master. A name is safe if and only if no character appears in both the first name and the last name.

Since no two clones can share a name, Darth Vader would like to know the maximum number of clones he is able to create.
 

Input
The First line of the input contains an integer T ( T10 ), denoting the number of test cases.

Each test case contains two integers n and m ( 1n,m2000 ).
 

Output
For each test case, output one line containing the maximum number of clones Vader can create.

Output the answer  mod 109+7
 

Sample Input
  
  
2 3 2 2 3
 

Sample Output
  
  
2 18
 
题意:

给克隆人起名字,要求每个克隆人有两个名字,长度都为n,两个名字不能有相同的字符,一共有m种字符可以选择,问最多可以给多少个克隆人起名字

思路:

看了官方题解,不会容斥原理,就去看了dp的解法。用递推的思想去解决,容易理解。假设dp[i][j]表示长度为i的名字选择了j种字符,则dp[i][j]=dp[i-1][j]*j+dp[i-1][j-1]*(m-(j-1))。长度为i选择j种字符的方案数=长度为(i-1)选择j种字符的方案数*j(因为前i-1位已选择j种字符,所以第i位只能选择前面j种字符中的一种)+长度为(i-1)选择(j-1)种字符的方案数*(m-(j-1))(因为前面i-1位选择了j-1种字符,所以第i位只能在剩下的m-(j-1)种字符中选)。然后第一个名字的方案数*第二个名字的方案数(第一个名字选择i种字符,第二个名字的只能在剩下的字符中选,因为每个名字有n位,所以为(m-i)^n种可能)就是答案~记得模除1e9+7

code:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod=1e9+7;
ll dp[2005][2005],ans;
ll speedmi(ll a,ll b)
{
        ll ans=1;
        while(b){
                if(b%2) ans=(ans*a)%mod;
                b/=2;
                a=(a*a)%mod;
        }
        return ans;
}
int main(){
        int t,n,m,i,j,k;
        scanf("%d",&t);
        while(t--){
                scanf("%d%d",&n,&m);
                dp[1][1]=m;
                for(i=2;i<=n;i++){
                        k=min(m,i);
                        for(j=1;j<=min(m,i);j++){
                                dp[i][j]=(dp[i-1][j]*j)%mod+(dp[i-1][j-1]*(m-j+1))%mod;
                        }
                }
                for(i=1,ans=0;i<m;i++){
                        ans+=(dp[n][i]*speedmi(m-i,n))%mod;
                        ans%=mod;
                }
                printf("%lld\n",ans);
        }
        return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值