组播综合实验

实验需求

本实验模拟跨域的组播网络环境,主要实现RP自动选举,组播与单播流量分离。
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

一、基础配置

1.1 所有设备的IPv4地址已配置,请自行查看。
1.2 配置OSPF协议,进程1,要求同AS内各设备环回口互通,不同AS的IGP不得互通。

二、部署PIM-SM

2.1 所有设备开启组播功能
2.2 除R3/4的Serial接口以外,所有物理接口开启PIM-SM。
2.3 R6的G0/0/2开启IGMP版本2。
2.4 R2/5使用Loopback0作为源接口,配置为候选BSR和候选RP。
2.5 R3/4部署BSR边界,防止R2/5成为其他AS的BSR或RP。

三、部署MP-BGP

3.1 R3/4部署BGP,AS号分别为123和456.
3.2 关闭default ipv4-unicast功能,避免自动建立ipv4单播邻居。
3.3 R3/4在高速链路34.1.1.0/24上建立ipv4组播邻居。
3.4 R3/4在低速链路134.1.1.0/24上建立ipv4单播邻居。
3.5 R3/4使用BGP的ipv4单播地址族,分别宣告R2/5的环回口路由。
3.6 R3/4将BGP路由引入OSPF。
3.7 确认R2/5的环回口互通。

四、部署MSDP

4.1 R2/5建立MSDP对等体。
4.2 PC1使用IGMPv2加入组224.1.1.1.
4.3 使用组播源MCS1发送组播流量至224.1.1.1
4.4 PC1打开VLC,发现无法收到组播,试分析原因。

五、RPF检查

5.1 单播RPF

5.1.1 在R3上使用BGP的ipv4单播地址族,宣告组播源192.168.1.0/24的路由。
5.1.2 确认R5收到组播源192.168.1.0/24的路由。
5.1.3 确认R5发送(192.168.1.1,224.1.1.1)组播路由给R4。
5.1.4 PC1依旧无法收到组播流量,分析原因。

5.2 MBGP

5.2.1 R3使用BGP的ipv4组播地址族,宣告组播源192.168.1.0/24的路由。
5.2.2 确认R4的组播RPF检查成功
5.2.3 确认R3收到(192.168.1.1,224.1.1.1)的组播路由。
5.2.4 确认PC1收到组播流量。

六. 代码

<R1>dis cu
[V200R003C00]
#
 sysname R1
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 192.168.1.254 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ip address 12.1.1.1 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
 ip address 13.1.1.1 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface NULL0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255 
 ospf enable 1 area 0.0.0.0
#
ospf 1 router-id 1.1.1.1 
 area 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
<R2>dis cu
[V200R003C00]
#
 sysname R2
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 12.1.1.2 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ip address 23.1.1.2 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255 
 pim sm
 ospf enable 1 area 0.0.0.0
#
ospf 1 router-id 2.2.2.2 
 area 0.0.0.0 
#
pim
 c-bsr LoopBack0
 c-rp LoopBack0
#
msdp
 peer 5.5.5.5 connect-interface LoopBack0
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
<R3>dis cu
[V200R003C00]
#
 sysname R3
#
 board add 0/1 2SA 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface Serial1/0/0
 link-protocol ppp
 ip address 134.1.1.3 255.255.255.0 
#
interface Serial1/0/1
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 13.1.1.3 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ip address 23.1.1.3 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
 ip address 34.1.1.3 255.255.255.0 
 pim bsr-boundary
 pim sm
#
interface NULL0
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.255 
 ospf enable 1 area 0.0.0.0
#
bgp 123
 undo default ipv4-unicast
 peer 34.1.1.4 as-number 456 
 peer 134.1.1.4 as-number 456 
 #
 ipv4-family unicast
  undo synchronization
  network 2.2.2.2 255.255.255.255 
  network 192.168.1.0 
  undo peer 34.1.1.4 enable
  peer 134.1.1.4 enable
 #
 ipv4-family multicast
  undo synchronization
  network 192.168.1.0 
  peer 34.1.1.4 enable
#
ospf 1 router-id 3.3.3.3 
 import-route bgp
 area 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
<R4>dis cu
[V200R003C00]
#
 sysname R4
#
 board add 0/1 2SA 
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface Serial1/0/0
 link-protocol ppp
 ip address 134.1.1.4 255.255.255.0 
#
interface Serial1/0/1
 link-protocol ppp
#
interface GigabitEthernet0/0/0
 ip address 34.1.1.4 255.255.255.0 
 pim bsr-boundary
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 45.1.1.4 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
 ip address 46.1.1.4 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface NULL0
#
interface LoopBack0
 ip address 4.4.4.4 255.255.255.255 
 ospf enable 1 area 0.0.0.0
#
bgp 456
 undo default ipv4-unicast
 peer 34.1.1.3 as-number 123 
 peer 134.1.1.3 as-number 123 
 #
 ipv4-family unicast
  undo synchronization
  network 5.5.5.5 255.255.255.255 
  undo peer 34.1.1.3 enable
  peer 134.1.1.3 enable
 #
 ipv4-family multicast
  undo synchronization
  peer 34.1.1.3 enable
#
ospf 1 router-id 4.4.4.4 
 import-route bgp
 area 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
<R5>dis cu
[V200R003C00]
#
 sysname R5
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 45.1.1.5 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ip address 56.1.1.5 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
 ip address 5.5.5.5 255.255.255.255 
 pim sm
 ospf enable 1 area 0.0.0.0
#
ospf 1 router-id 5.5.5.5 
 area 0.0.0.0 
#
pim
 c-bsr LoopBack0
 c-rp LoopBack0
#
msdp
 peer 2.2.2.2 connect-interface LoopBack0
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
<R6>dis cu
[V200R003C00]
#
 sysname R6
#
 snmp-agent local-engineid 800007DB03000000000000
 snmp-agent 
#
 clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load flash:/portalpage.zip
#
 drop illegal-mac alarm
#
multicast routing-enable
#
 wlan ac-global carrier id other ac id 0
#
 set cpu-usage threshold 80 restore 75
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default 
 domain default_admin 
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http
#
firewall zone Local
 priority 15
#
interface GigabitEthernet0/0/0
 ip address 46.1.1.6 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/1
 ip address 56.1.1.6 255.255.255.0 
 pim sm
 ospf enable 1 area 0.0.0.0
#
interface GigabitEthernet0/0/2
 ip address 192.168.6.254 255.255.255.0 
 pim sm
 igmp enable
 ospf enable 1 area 0.0.0.0
#
interface NULL0
#
interface LoopBack0
 ip address 6.6.6.6 255.255.255.255 
#
ospf 1 router-id 6.6.6.6 
 area 0.0.0.0 
#
user-interface con 0
 authentication-mode password
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
  • 3
    点赞
  • 23
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

土豆aaa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值