1056. Mice and Rice (25)

1056. Mice and Rice (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

思路:使用队列的方法让老鼠不断的入队出队,实现每轮次的晋级操作。



#include<stdio.h>
#include<stdlib.h> 
#include<math.h>
#include<string.h>
#include<algorithm>
#include <vector> 
#include<stack> 
#include <queue>  
#include<map>
#include<iostream>  
#include <functional> 
#define MAX 1001
#define MAXD 6
#define TELNUM 10
using namespace std;

struct mouse{
	int weight;
	int rank;
}mouse[MAX];

int main(void)
{
	int Np,Ng;
	queue<int> q;
	scanf("%d%d",&Np,&Ng);
	
	for(int i = 0; i < Np; i++)
	{
		scanf("%d",&mouse[i].weight);
	}
	
	int n;
	for(int i = 0; i < Np; i++)
	{
		scanf("%d",&n);
		q.push(n);/*将老鼠的编号依次入队*/
	}
	
	int temp = Np;
	int group;
	
	while(q.size() != 1)/*按照队列中老鼠序号的排序,选出每轮晋级的老鼠,直到选出队列中最大的那只老鼠*/
	{
		if(temp % Ng == 0)/*把老鼠分别分成Ng个一组,最后不够Ng个单独为一组*/
		{
			group = temp / Ng;
		}
		else
		{
			group = temp / Ng + 1;
		}
		
		for(int i = 0; i < group; i++)/*选出小组中质量大的那个晋级*/ 
		{
			int k = q.front();/*k表示质量最大的老鼠编号*/
			for(int j = 0; j < Ng; j++)
			{
				if(i * Ng + j >= temp)break;
				int front = q.front();
				
				if(mouse[k].weight < mouse[front].weight)
				{
					k = front;	
				}
				mouse[front].rank = group + 1;/*该轮的老鼠名次都为group + 1*/
				q.pop();/*该老鼠出队*/
			}
			q.push(k);/*将小组最大的老鼠再次入队*/
		}
		temp = group;/*此轮有group只老鼠晋级,这group只老鼠是下轮比较的总数*/
	}
	
	mouse[q.front()].rank = 1;/*最后选出来的老鼠排名为 1*/
	
	for(int i = 0; i < Np; i++)
	{
		printf("%d",mouse[i].rank);
		if(i < Np - 1)
		printf(" ");
	}
	
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值