Matrix Swapping II hdu2830

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1931    Accepted Submission(s): 1297


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.
We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
  
  
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
  
  
4 2 Note: Huge Input, scanf() is recommended.
尽然忘了加代码。。。真是蠢的不行。。
import java.util.Arrays;
import java.util.Scanner;

public class hdu2830 {
	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNextLine()) {
			String[] s = scanner.nextLine().trim().split(" ", 2);
			if (s[0] == null || s[0].equals(""))
				break;
			int n = Integer.valueOf(s[0]);
			int m = Integer.valueOf(s[1]);
			int[][] high = new int[n + 2][m + 2];

			// 预处理每行的高度
			for (int i = 0; i < n; i++) {
				String line = scanner.nextLine().trim();
				for (int j = 0; j < line.length(); j++) {
					if (line.charAt(j) == '1')
						high[i + 1][j + 1] = high[i][j + 1] + 1;
				}
			}

			// 处理每一行
			int area = 0;
			for (int i = 1; i <= n; i++) {
				int[] h = new int[m + 2];
				h[0] = -1;		
				h[m + 1] = Integer.MAX_VALUE;	//为了排序不乱,把数组最后一个数设为最大值,排完序再修改回来
				for (int j = 1; j <= m; j++)
					h[j] = high[i][j];
				Arrays.sort(h);
				h[m + 1] = -1;
//				for (int j = 0; j <= m+1; j++)
//					System.out.print(h[j]+" ");
//				System.out.println();
				int[] left = new int[m + 2];
				int[] right = new int[m + 2];
				left[0] = 1;
				right[m + 1] = -1;

				for (int j = 1; j <= m; j++) {
					left[j] = j;
					while (h[left[j] - 1] >= h[j])
						left[j] = left[left[j] - 1];
				}

				for (int j = m; j >= 1; j--) {
					right[j] = j;
					while (h[right[j] + 1] >= h[j])
						right[j] = right[right[j] + 1];
				}
				
//				for (int j = 0; j <= m+1; j++)
//					System.out.print(left[j]+" ");
//				System.out.println();
//				
//				for (int j = 0; j <= m+1; j++)
//					System.out.print(right[j]+" ");
//				System.out.println();
				
				for (int j = 1; j <= m; j++) {
					if (area < (right[j] - left[j] + 1) * h[j])
						area = (right[j] - left[j] + 1) * h[j];
				}
			}
			System.out.println(area);
		}
		scanner.close();
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值