解题报告:HDU_1709 The Balance

Description

Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

Input

The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

Output

For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

Sample Input

3
1 2 4
3
9 2 1

Sample Output

0
2
4 5


类型:母函数水题

大意:给你几个砝码,找出总重量内的无法通过给定的砝码称的重量,输出称不出的个数,并依次输出重量(如果不为0)。

思路:用一个数组A记录可以称的质量,初始始A[0]=1;每次输入一个砝码重量,将其与之前已经可以称出的重量做加减,并把对应的C组中四个值(A,A+tem,abs(A-tem),tem)的赋1,表示这四个值都是可以称得出来的。然后将C数组中的值全部赋给A,每次使用C数组前清0;最后统计无法称得的重量时用B数组记录以节省一定的时间,做好这题后看了看标算,发现差不多的,还是挺开心的



#include<cstdio>
#include<algorithm>
#include<algorithm>
#include<cstring>
#define N 101
using namespace std;
int A[N*N],B[N*N],C[N*N];

int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        memset(A,0,sizeof(A));
        memset(B,-1,sizeof(B));
        A[0]=1;
        int sum=0,tem;
        for(int i=0;i<n;i++)
        {
            memset(C,0,sizeof(C));
            scanf("%d",&tem);
            for(int j=sum;j>=0;j--)
                if(A[j])
                {
                    C[j+tem]=C[abs(j-tem)]=C[tem]=C[j]=1;
                }
            sum+=tem;
            for(int j=0;j<=sum;j++)
                A[j]=C[j];
        }
        //printf("sum=%d\n",sum);
        int k=0;
        for(int i=0;i<sum;i++)
        {
            //printf("A[%d]=%d\n",i,A[i]);
            if(!A[i])
                B[k++]=i;
        }
        if(!k)
            printf("0");
        else
            {
                printf("%d\n",k);
                for(int i=0;i<k;i++)
                {
                    if(i)
                        printf(" ");
                    printf("%d",B[i]);
                }
            }
        printf("\n");
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值