解题报告:HDU1695(欧拉+容斥)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9088    Accepted Submission(s): 3366


Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 
一句话题意 就是求gcd(x,y)==k的组合数,其中x属于[1,b],y属于[1,d]。


思路:

欧拉加容斥,要预处理,不然会超时。好像也可以用莫比乌斯反演,不知道效率怎么样,高的话下次把它一起整理上来。
这题还是有点点复杂的,简单记录一下思路:
先将b和d同除以k转换成求x属于(1,b/k),y属于(1,d/k)的__gcd(x,y)==1的问题
然后遍历y,当y<=b/k时,加上y的欧拉值(表示其中y选y时,x的可选的数目,x<y)
当y>b/k时,问题就复杂一点,我们要求的是[1,b/k]中与y互质的个数,这时候就要用到容斥:
y - ( 奇数个素因子的倍数个数和 - 偶数个素因子的倍数个数和) 
就是该y对应的符合要求x的个数了 。 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#pragma comment(linker, "/STACK:102400000,102400000")
using namespace std;
const int N = 1e5+5;
int phi[N];
vector<int>e[N];


inline void init(){
    memset(phi,0,sizeof(phi));
    phi[1]=1;
    for(int i=2;i<=N;i++)
    {
        if(!phi[i])for(int j=i;j<=N;j+=i)
        {
            e[j].push_back(i);
            if(!phi[j])phi[j]=j;
            phi[j] = phi[j]/i*(i-1);
        }if(phi[i]==i-1){
            e[i].push_back(i);
        }
    }
}

inline int dfs(int id,int need,int x,int y,int sum){
    if(need==0){
        return y/sum;
    }int res = 0;
    for(int i=id;i<e[x].size();i++)
    {
        res += dfs(i+1,need-1,x,y,sum*e[x][i]);
    }return res;
}

inline int work(int x,int y){
    int res = 0;
    for(int i=0;i<e[x].size();i++)
        res += dfs(0,i+1,x,y,1)*(i%2?-1:1);
    return y-res ;
}


int main()
{
    int T,t=0;init();
    scanf("%d",&T);
    while(T--)
    {
        int a,b,c,d,gcd;
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&gcd);
        if(gcd==0){
            printf("Case %d: 0\n",++t);
            continue;
        }
        if(b>d)swap(b,d);int n = d / gcd , m =b/gcd;
        long long ans = 0;
        for(int i=1;i<=n;i++){
            if(i<=m)
                ans += phi[i];
            else {
                ans += work(i,m);
            }
        }
        printf("Case %d: %I64d\n",++t,ans);
    }return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值