第八届河南省程序设计大赛-NYOJ-1241-Distribution(水题)

Distribution
时间限制:1000 ms | 内存限制:65535 KB
难度:1
描述
One day , Wang and Dong in the Dubai desert expedition, discovered an ancient castle. Fortunately, they found a map of the castle.The map marks the location of treasures.

They agreed to distribute the treasures according to the following rules:
这里写图片描述

Wang draws a horizontal line on the map and then Dong draws a vertical one so that the map is divided into 4 parts, as show below.

Wang will save the treasures in I and III ,while those situated in II and IV will be taken away by Dong. Wang first draw a horizontal line, Dong after the draw a vertical line.

They drew several pairs of lines. For each pair, Wang wants to know the difference between their treasures.

It’s guaranteed that all the reasures will lie on neither of the lines drew by them.

输入
the first line contains two integers N and M, where N is the number of treasures on the map and M indicates how many times they are going to draw the lines. The 2nd to (N+1)-th lines Xi, Yi contain the co-ordinates of the treasures and the last M lines consist of the M pairs integers (X, Y) which means that the two splitting lines intersect at point (X, Y).
( 0 < N, M ≤ 100, 0 ≤ Xi, Yi, X,Y ≤ 1000 )
输出
Output contains M lines , a single line with a integer , the difference described above
样例输入
10 3
29 22
17 14
18 23
3 15
6 28
30 27
4 1
26 7
8 0
11 21
2 25
5 10
19 24
样例输出
-6
4
4
来源
第八届河南省程序设计大赛

题意:首行给出N,M;然后给出N个宝藏坐标,然后给出M个画线的交点坐标,输出每次画线后区域一+三-二-四的结果

去年省赛最简单的一道水题吧,想想去年省赛举办的时候刚好是五月份,我还在上高三(或者说被高三上)。

题解:略(真没什么说的。。。。)

代码

#include<stdio.h>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<math.h>
#include<limits.h>
#include<iostream>
#include<algorithm>
using namespace std;
//省赛水题
struct node
{
    int x;
    int y;
} map[1005]; //接收数据
int main()
{
    int N,M;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(int i=0; i<N; i++) //接收宝藏坐标
            scanf("%d%d",&map[i].x,&map[i].y);
        for(int i=0; i<M; i++) //M次画线
        {
            int flag_x,flag_y;//画线交点坐标
            int sum1=0,sum2=0,sum3=0,sum4=0;//四个部分的宝藏数量
            scanf("%d%d",&flag_x,&flag_y);
            for(int j=0; j<N; j++)
            {
                if(map[j].x>flag_x&&map[j].y>flag_y)
                    sum1++;
                else if(map[j].x<flag_x&&map[j].y>flag_y)
                    sum2++;
                else if(map[j].x<flag_x&&map[j].y<flag_y)
                    sum3++;
                else
                    sum4++;
            }
            printf("%d\n",sum1+sum3-sum2-sum4);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值