POJ-2155-Matrix

I - Matrix POJ 2155
Time Limit: 3000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status]

Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].
    Input
    The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1

题意:输入第一行是数据组数,每组数据第一行是N和T,N代表正方形地图的尺寸,地图默认都是0,T代表操作的次数。以下是T行操作,操作分为两种,C后面跟两组坐标,x1,y1,x2,y2,表示改变以这两点为对角的矩形内的地图值(原始是0就改为1,原始是1就改为0),Q后面跟一组坐标,输出这个坐标对应地图的值(1或者0)

二维树状数组:类比于一维的,更新查找求和数组时,需要用两层for循环。千万不要像一维的一样画个图出来(我也画不出来),这东西就像递归,全靠想(所以只会模仿模板)

思路:用二维树状数组记录下每个坐标的翻转次数总和,然后对2取余就知道坐标的实际情况

代码

#include<stdio.h>
#include<string.h>
#include<string>
#include<stack>
#include<queue>
#include<math.h>
#include<limits.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAX=1010;
int map[MAX][MAX];//二维树状数组,地图,记录坐标被翻转的次数
int n;//地图大小
int Lowbit(int x)//返回x二进制最后一位1的权值
{
    return x&(-x);
}
void Updata(int x,int y)//更新二维树状数组
{
    int i,k;//只要满足条件就一直标记
    for(i=x; i<=n; i+=Lowbit(i))
        for(k=y; k<=n; k+=Lowbit(k))
            map[i][k]++;
}
int Get(int x,int y)//查找
{
    int sum = 0;//记录要查找坐标的翻转次数和
    for(int i=x; i>0; i-=Lowbit(i))
        for(int k=y; k>0; k-=Lowbit(k))
            sum+=map[i][k];
    return sum;//返回坐标翻转的总次数
}
int main()
{
    int ncases,m;
    int x1,y1,x2,y2;//操作起始终止坐标
    char ch[2];
    scanf("%d",&ncases);
    while(ncases--)
    {
        memset(map,0,sizeof(map));//地图初始化为0
        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%s",ch);
            if(ch[0]=='C')//更新
            {
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                x1++;
                y1++;
                x2++;
                y2++;
                Updata(x2,y2);//更新矩阵内坐标翻转次数总和
                Updata(x1-1,y1-1);
                Updata(x1-1,y2);
                Updata(x2,y1-1);
            }
            else
            {
                scanf("%d%d",&x1,&y1);
                printf("%d\n",Get(x1,y1)%2);//只需输出坐标翻转次数%2
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值