BNUOJ-24431-Crossed ladders

B. Crossed ladders
Time Limit: 1000msMemory Limit: 32768KB 64-bit integer IO format: %I64d Java class name: Main
Submit Status PID: 24431
A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?

这里写图片描述

Input
Each line of input contains three positive floating point numbers giving the values of x, y, and c.
Output
For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.
Sample Input
30 40 10
12.619429 8.163332 3
10 10 3
10 10 1
Sample Output
26.033
7.000
8.000
9.798

题意:给出长度为x,y的两条直线,两直线交点到地平线距离为c,求两直线与地平线交点距离。

思路:不要去算公式,至少大一的数学知识还解决不了这么复杂的方程。注意输出要求保留小数点后三位数,也就是说,输出的不一定是精确值,那么可以采用高中学的二分无限逼近最终结果,只要精度足够,就可以近似认为找到了精确值。

代码

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    double x,y,c;
    while(~scanf("%lf%lf%lf",&x,&y,&c))
    {
        double left=0.0;
        double right=min(x,y);
        double mid;
        while(right-left>=0.0001)//控制精度
        {
            mid=(left+right)/2;
            if((sqrt(x*x-mid*mid)*sqrt(y*y-mid*mid))/(sqrt(x*x-mid*mid)+sqrt(y*y-mid*mid))<c)
                right=mid;
            else
                left=mid;
        }
        printf("%.3lf\n",left);
    }
    return 0;
}

当时解了一个多小时的方程,才想起来二分逼近。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值