ZOJ-1610- Count the Colors(端点染色,Lazy算法)

F - Count the Colors
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

ZOJ 1610
Description
Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1
1 1

0 2
1 1

巧妙点的端点染色,并没有用到线段树
代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=8005;
int color[maxn];//记录染色
int num[maxn];//颜色为i的区域有num[i]个
int N;//操作数量
int main()
{
    while(~scanf("%d",&N))
    {
        memset(color,0,sizeof(color));//初始化color染色为正无穷
        memset(num,0,sizeof(num));
        while(N--)//接收数据并染色
        {
            int a,b,c;//含义如题
            scanf("%d%d%d",&a,&b,&c);
            for(int i=a; i<b; i++)
                color[i]=c+1;//记录加一,方便后面判断
        }
        for(int i=0; i<maxn; i++)//这里可以优化
        {
            while(i!=0&&color[i]&&color[i]==color[i-1])//i不是首位,i颜色不为空,i和前一个人的颜色相同
                i++;//跳过这个i
            if(color[i])//如果i的颜色不为空
                num[color[i]-1]++;//注意前面加一,这里记录时要减一
        }
        for(int i=0; i<maxn; i++)
            if(num[i])
                printf("%d %d\n",i,num[i]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值