HDU-1698-Just a Hook(再写Lazy)

B - Just a Hook
Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.

重水了一遍
代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const int maxn=100005;
//线段树区间修改求和
//Lazy延迟更新
int num[maxn<<2];
int Lazy[maxn<<2];
void Push_Up(int root)
{
    num[root]=num[root<<1]+num[root<<1|1];
}
void Push_Down(int root,int len)
{
    if(Lazy[root]!=-1)
    {
        Lazy[root<<1]=Lazy[root];
        Lazy[root<<1|1]=Lazy[root];
        num[root<<1]=Lazy[root]*(len-(len>>1));
        num[root<<1|1]=Lazy[root]*(len>>1);
        Lazy[root]=-1;
    }
}
void Build(int root,int left,int right)
{
    Lazy[root]=-1;//初始化为无需更新
    if(left==right)//这里可能有问题
    {
        num[root]=1;
        return;
    }
    int mid=(left+right)>>1;
    Build(root<<1,left,mid);
    Build(root<<1|1,mid+1,right);
    Push_Up(root);
}
void Update(int root,int left,int right,int find_left,int find_right,int change_num)
{
    if(left>=find_left&&right<=find_right)
    {
        Lazy[root]=change_num;
        num[root]=(right-left+1)*change_num;
        return;
    }
    Push_Down(root,right-left+1);//数据下沉一层
    int mid=(left+right)>>1;
    if(find_right<=mid)
        Update(root<<1,left,mid,find_left,find_right,change_num);
    else if(find_left>mid)
        Update(root<<1|1,mid+1,right,find_left,find_right,change_num);
    else
    {
        Update(root<<1,left,mid,find_left,mid,change_num);
        Update(root<<1|1,mid+1,right,mid+1,find_right,change_num);
    }
    Push_Up(root);//数据上浮
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int casen=1; casen<=T; casen++)
    {
        int N;//N个数
        scanf("%d",&N);
        Build(1,1,N);
        int M;//M此操作
        scanf("%d",&M);
        while(M--)
        {
            int X,Y,Z;//含义如题
            scanf("%d%d%d",&X,&Y,&Z);
            Update(1,1,N,X,Y,Z);
        }
        printf("Case %d: The total value of the hook is %d.\n",casen,num[1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值