POJ-3278-Catch That Cow(BFS)

C - Catch That Cow
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 3278
Appoint description:
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

当N大于K时直接输出N-K,否则数组会越界

代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
const int maxn=100001;
int map[maxn];
int N;
int K;
struct node
{
    int x;
    int steap;
};
void BFS(int N,int K)
{
    memset(map,0,sizeof(map));
    node star;
    star.x=N;
    star.steap=0;
    queue<node>q;
    q.push(star);
    while(!q.empty())
    {
        star=q.front();
        q.pop();
        if(star.x==K)
        {
            printf("%d\n",star.steap);
            return;
        }
        node end;
        end.x=star.x+1;
        if(end.x>0&&end.x<maxn&&map[end.x]==0)
        {
            end.steap=star.steap+1;
            q.push(end);
            map[end.x]=1;
        }
        end.x=star.x-1;
        if(end.x>0&&end.x<maxn&&map[end.x]==0)
        {
            end.steap=star.steap+1;
            q.push(end);
            map[end.x]=1;
        }
        end.x=star.x*2;
        if(end.x>0&&end.x<maxn&&map[end.x]==0)
        {
            end.steap=star.steap+1;
            q.push(end);
            map[end.x]=1;
        }
    }
}
int main()
{
    while(~scanf("%d%d",&N,&K))
    {
        if(N>K)
            printf("%d\n",N-K);
        else
            BFS(N,K);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值