E - Find The Multiple
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
POJ 1426
Appoint description:
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题意:给出N,找出M,使得M除以N没有余数,即M/N*N==M,且M仅由0或1组成,如果有多个M,随便输出一个即可。
思路一:枚举M的个十百千万每一位,一遍BFS即可。
思路二:深搜一遍,不过要注意最多搜到19层,20层就存不下了
BFS代码(344ms)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int N;
struct node
{
long long int x;
friend bool operator <(node n1,node n2)
{
return n1.x>n2.x;
}
};
void BFS(int N)
{
node star;
star.x=1;
priority_queue<node>q;
q.push(star);
while(!q.empty())
{
star=q.top();
q.pop();
node end;
end.x=star.x*10;
if(end.x/N*N==end.x)
{
// printf("*****");
printf("%I64d\n",end.x);
return;
}
// printf("%d\n",end.x);
q.push(end);
end.x=star.x*10+1;
if(end.x/N*N==end.x)
{
printf("%I64d\n",end.x);
return;
}
// printf("%d\n",end.x);
q.push(end);
}
}
int main()
{
while(~scanf("%d",&N)&&N)
{
BFS(N);
}
return 0;
}
DFS代码(157ms)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
int N;
int flag;
void DFS(int N,unsigned __int64 Result,int k)//k代表搜索的层数,第20层就存不下了
{
if(flag==1)
return;
if(Result%N==0)
{
flag=1;//标记已经搜到
printf("%I64u\n",Result);
return;
}
if(k==19)
return;
DFS(N,Result*10,k+1);
DFS(N,Result*10+1,k+1);
}
int main()
{
while(~scanf("%d",&N)&&N)
{
flag=0;
DFS(N,1,0);
}
return 0;
}