POJ-3984-迷宫问题(BFS)

I - 迷宫问题
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 3984
Appoint description:
Description
定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

一遍广搜并且保存路径即可

代码

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<queue>
#include<math.h>
using namespace std;
int map[10][10];//存图
int vis[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
    int x;
    int y;
    int steap;//记录步数,同时也是str的下标
    int num_x[255];//存储路径
    int num_y[255];
};
bool Judge(int x,int y)
{
    if(x>=0&&x<5&&y>=0&&y<5&&map[x][y]==0)
        return true;
    return false;
}
void BFS()
{
    queue<node>q;
    node star;
    star.x=0;
    star.y=0;
    star.steap=0;
    star.num_x[0]=0;
    star.num_y[0]=0;
    map[0][0]=1;//起点标记为已走过
    q.push(star);
    while(!q.empty())
    {
        star=q.front();
        q.pop();
        if(star.x==4&&star.y==4)
        {
            for(int i=0; i<=star.steap; i++)
                printf("(%d, %d)\n",star.num_x[i],star.num_y[i]);
            return;
        }
        //四个方向搜索
        for(int i=0; i<4; i++)
        {
            node end=star;
            end.x+=vis[i][0];
            end.y+=vis[i][1];
            if(Judge(end.x,end.y))
            {
                end.steap++;
                end.num_x[end.steap]=end.x;
                end.num_y[end.steap]=end.y;
                map[end.x][end.y]=1;
                q.push(end);
            }

        }
    }
}
int main()
{
    for(int i=0; i<5; i++)
    {
        for(int j=0; j<5; j++)
            scanf("%d",&map[i][j]);
        getchar();
    }

    BFS();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值