Tian Ji -- The Horse Racing(贪心 博弈)

Tian Ji – The Horse Racing
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

这里写图片描述

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output
200
0
0

题意:英文版田忌赛马,多组数据,每组数据第一行给出N,代表田忌和齐王各有N匹马,接下来一行N个数代表田忌马的速度,再接下来一行代表齐王马的数量,输出田忌最多可以胜利几场

思路:首先对两人马的速度升序排列,接着按一下步骤安排比赛。
首先比较田忌和齐王最快马的速度。
如果田忌最快的马比齐王最快的马还要快,那就让这两匹马跑一场(田忌肯定赢)
如果田忌最快的马比齐王最快的马慢,那就让田忌最慢的马和齐王最快的马比一场(消耗齐王的好马)
如果田忌最快的马和齐王最快的马一样快,那就接着比较两人最慢的马。
如果田忌最慢的马比齐王最慢的马快,那就让这两匹马跑一场(田忌又能赢了)
如果田忌最慢的马小于等于齐王最慢的马,那就让田忌最慢的马和齐王最快的马比(接着消耗齐王的好马)

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
int main()
{
    int N;
    while(~scanf("%d",&N)&&N)
    {
        int Tian[1005];
        int King[1005];
        for(int i=0; i<N; i++)
            scanf("%d",&Tian[i]);
        for(int i=0; i<N; i++)
            scanf("%d",&King[i]);
        sort(Tian,Tian+N);
        sort(King,King+N);
        int Left_Tian=0;//指向未匹配马中速度最快和最慢的马
        int Right_Tian=N-1;
        int Left_King=0;
        int Right_King=N-1;
        int result=0;//记录胜利和失败的数量
        do
        {
            if(Tian[Right_Tian]>King[Right_King])//如果Tian最快的比King最快的快
            {
                Right_Tian--;
                Right_King--;
                result++;//这局可以比
            }
            else if(Tian[Right_Tian]==King[Right_King])//如果Tian最快的和King最快的相等
            {
                //开始比较较慢的马
                if(Tian[Left_Tian]>King[Left_King])//如果Tian最慢的比King最慢的快
                {
                    result++;//那就让它俩比一场
                    Left_Tian++;
                    Left_King++;
                }
                else if(Tian[Left_Tian]<=King[Left_King])//如果Tian最慢的小于等于King最慢的
                {

                    if(Tian[Left_Tian]<King[Right_King])//用Tian最慢的消耗King最快的,如果最后输了,就记录下来

                        result--;
                    Left_Tian++;//
                    Right_King--;
                }
            }
            else//如果Tian最快的马比King最快的马慢
            {
                Left_Tian++;//用Tian最慢的消耗King最快的
                Right_King--;
                result--;
            }
        }
        while(Right_Tian>=Left_Tian);//还有马没比,就进入循环
        printf("%d\n",result*200);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值