Wooden Sticks(贪心)

Wooden Sticks
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3

题意:首行给出T,代表有T组数据。每组数据第一行给出N,代表接着一行有N个区间共N*2组数据,接着一行给出每个区间的左右区间,如果区间的左坐标大于等于上一个区间的左坐标且区间的右坐标大于等于上一个区间的右坐标,那么计数不变,否则计数加一,输出最小计数。

思路:根据每个区间的右坐标升须排列,如果右坐标相同,按左坐标升序排列。然后逐个遍历,实时更新当前左右坐标。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
const int maxn=10005;
struct node
{
    int l;
    int w;
    int flag;//初始化为0,已处理标记为1
} num[maxn];
bool cmp(node x,node y)
{
    if(x.l==y.l)
        return x.w<y.w;
    return x.l<y.l;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int N;
        scanf("%d",&N);
        for(int i=0; i<N; i++)
        {
            scanf("%d%d",&num[i].l,&num[i].w);
            num[i].flag=0;
        }
        sort(num,num+N,cmp);
        int result=0;
        for(int i=0; i<N; i++)
        {
            if(num[i].flag==0)
            {
                num[i].flag=1;
                int left=num[i].l;
                int right=num[i].w;
                result++;
                for(int j=0; j<N; j++)
                {
//                    printf("****");
                    if(num[j].flag==0&&num[j].l>=left&&num[j].w>=right)
                    {

                        left=num[j].l;
                        right=num[j].w;
                        num[j].flag=1;
                    }
                }
            }
        }
        printf("%d\n",result);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值