Yogurt factory(贪心)

Yogurt factory
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.
Input
* Line 1: Two space-separated integers, N and S.

  • Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
    Output
  • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
    Sample Input
    4 5
    88 200
    89 400
    97 300
    91 500
    Sample Output
    126900
    Hint
    OUTPUT DETAILS:
    In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

题意:首行给出N和S,代表接下来有N组数据,也就是要生产N周牛奶。每组数据C[i]代表生产牛奶的单价,Y[i]代表本周牛奶的需求量,你可以选择只生产本周的,也可以选择把后几周的都生产(因为本周成本低),但是存储每周没单位牛奶需要S,输出满足所有周需求需要最小的生产成本。

思路:可以动态规划,但这里采用的是更容易理解的贪心。倒叙遍历每周,对于第i周,遍历比较i-1到1的最小生产代价即可。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;
const int maxn=10005;
int main()
{
    int N;//数据组数
    int S;//存储每周每单位花费
    while(~scanf("%d%d",&N,&S))
    {
        int C[maxn];//花费单价为C[i]
        int Y[maxn];//需求量为Y[i]
        for(int i=0; i<N; i++)
            scanf("%d%d",&C[i],&Y[i]);
        long long int sum=0;//记录总花费
        for(int i=N-1; i>=0; i--)
        {
            int min_cost=C[i];//寻找对于Y[i]来说最小的成本
            for(int j=i-1; j>=0; j--)//向前遍历寻找最小生产成本
                if(C[j]+S*(i-j)<min_cost)
                    min_cost=C[j]+S*(i-j);
            sum+=min_cost*Y[i];
        }
        printf("%I64d\n",sum);
    }
    return 0;
}
//还可以动态规划
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值