POJ-3259-Wormholes(SPFA 链表建立邻接表)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44217 Accepted: 16262
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES
Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:给出N,M,W,代表有N个点,M条无向边,W条有向边(权值为负),判断从1开始回到1有没有负权回路

第一次用指针建立邻接表

代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
//SPFA判断负权回路
//换用新的邻接表
const int maxn=600;
const int INF=0x3f3f3f3f;
struct ArcNode
{
    int to;
    int weiget;
    ArcNode *next;
};
ArcNode *List[maxn];//表头指针
int vis[maxn];//顶点是否在队列中
int dis[maxn];
int num[maxn];//顶点入队次数
int N,M,W;
bool SPFA(int star)
{
//    ArcNode *temp;
    vis[star]=1;
    dis[star]=0;
    num[star]++;
    queue<int>q;
    q.push(star);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        if(num[u]>N)
            return true;
//        temp=List[u];//取出顶点u的头指针
        for(ArcNode *temp=List[u]; temp!=NULL; temp=temp->next)
        {
            int v=temp->to;
            if(dis[v]>dis[u]+temp->weiget)
            {
                dis[v]=dis[u]+temp->weiget;
                if(vis[v]==0)
                {
                    q.push(v);
                    vis[v]=1;
                    num[v]++;
                }
            }
        }
    }
    return false;
}
void init_map()
{
    for(int i=0; i<maxn; i++)
    {
        List[i]=0;
        vis[i]=0;
        dis[i]=INF;
        num[i]=0;
    }
    ArcNode *temp;
    int u,v,w;
    for(int i=1; i<=M; i++)
    {
        scanf("%d%d%d",&u,&v,&w);
        temp=new ArcNode;
        temp->to=u;
        temp->weiget=w;
        temp->next=NULL;
        if(List[v]==NULL)
            List[v]=temp;
        else
        {
            temp->next=List[v];
            List[v]=temp;
        }
        temp=new ArcNode;
        temp->to=v;
        temp->weiget=w;
        temp->next=NULL;
        if(List[u]==NULL)
            List[u]=temp;
        else
        {
            temp->next=List[u];
            List[u]=temp;
        }
    }
    for(int i=1; i<=W; i++)
    {
        scanf("%d%d%d",&u,&v,&w);
        temp=new ArcNode;
        temp->to=v;
        temp->weiget=-w;
        temp->next=NULL;
        if(List[u]==NULL)
            List[u]=temp;
        else
        {
            temp->next=List[u];
            List[u]=temp;
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&N,&M,&W);
        init_map();
        SPFA(1)==true?printf("YES\n"):printf("NO\n");
        for(int i=1;i<maxn;i++)//清空链表
        {
            ArcNode *temp=List[i];
            while(temp!=NULL)
            {
                List[i]=temp->next;
                delete temp;
                temp=List[i];
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值